Attaching file with names that conatin %hh in them are not all processed properly

RESOLVED DUPLICATE of bug 379053

Status

RESOLVED DUPLICATE of bug 379053
10 years ago
9 years ago

People

(Reporter: mozbugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: version 2.0.0.17 (20080914)

Some file names that contain %hh strings in them do not get properly processed when attaching to an e-mail. The error that appears suggests the %hh string is being converted to HTML equivalent text (i.e.: %2b = +).

Some strings seem to be handled OK. For example, test%20k.lkl worked fine, but space%20test.txt did not.

All my test files were 0 bytes in length, changing only the file name.


Reproducible: Always

Steps to Reproduce:
1. Create a file on your computer: c:\plus%2btest.txt
2. Attach this file to an e-mail message. The "Attachments" pane shows plus%2btest.txt
3. Click send. An error appears: Sending of message failed. Unable to open the temporary file c:\plus+test.txt. Check your 'Temporary Directory' setting.
Actual Results:  
An error appears: Sending of message failed. Unable to open the temporary file c:\plus+test.txt. Check your 'Temporary Directory' setting.

Expected Results:  
Thunderbird should properly attach and send the file as plus%2btest.txt

Reproducibility "every time" because once you find one of these names, it happens every time with that name.
Dup of Bug 379053?

> Some strings seem to be handled OK. For example, test%20k.lkl worked fine,
> but space%20test.txt did not.

File extension has relation to problem?
(Mime-type for ".lkl" is not usually defined or is unknow, then application/octet-stream is perhaps used.)
Or difference between "test"(even char number before ".") and "k"(odd char number before ".")?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379053
You need to log in before you can comment on or make changes to this bug.