CSS not rendering with served with wrong content-type

RESOLVED DUPLICATE of bug 156145

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 156145
9 years ago
9 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_5; en-gb) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

In an effort to conserve bandwidth I started hosting my CSS on Amazon S3.  It turns out that the FTP client I used would set the content-type metadata of the uploaded files to binary/octet-stream.  This content type is used when the file is served.

In the example page the CSS file is hosted on S3 and when Firefox loads the CSS, it is sent with a content-type of binary/octet-stream.  The CSS then fails to render on the page.  If I reset the metadata content-type to text/css then Firefox renders it perfectly.  If I host the CSS on an Apache server (that presumably serves the file with the correct content type) Firefox renders it fine.

In all cases Safari and IE are not affected by the content-type header, only Firefox has problems with the CSS, although using Firebug I can view the CSS fine.

Reproducible: Always

Steps to Reproduce:
1. Visit the example page I setup, http://s3.playr.co.uk/s3.cssbug.html
2.
3.
Actual Results:  
The CSS did not render at all; the header was black, there was no border on the first paragraph.

Expected Results:  
The CSS should render properly; the header should be red and there should be a border on the first paragraph.

Works fine on Safari, IE, just not FF.  Have not tested with other versions of FF though.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 156145
You need to log in before you can comment on or make changes to this bug.