Firefox 3 cookie dialog is 'broken' - bring back FF2 behavior (at least as an OPTION)

RESOLVED DUPLICATE of bug 405239

Status

()

--
major
RESOLVED DUPLICATE of bug 405239
10 years ago
10 years ago

People

(Reporter: dovholukspam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

PLEASE READ before marking/resolving as a dupe...

Firefox 3 has chosen to steal the focus from whatever window, whatever tab one is currently on when a page wants to set a cookie and one has the "ask me every time" option selected.

This behavior is broken in FF3 AND in FF2 however FF2 doesn't cause the same level of frustration that FF3 does.  Instead FF3 will 'steal' the focus from whatever window/tab one is currently on and move you to the location of the cookie request.  This is VERY cumbersome when one opens many pages and all of which are slow to load... As the pages respond one gets barraged with bouncing tabs, all of which asking to set cookies.

Strangely enough - this too is actually broken.  Assume this scenario: one opens 10 windows - all of which set a cookie, and all of which load at different speeds.  The FF3 dialog comes up asking about the cookie - but one does NOT answer the modal immediately (say - you went to the fridge).  When one comes back - all the cookie requests are on the SAME window.

Instead of the current behavior, these modal windows should "queue" until the user activates the window in question.  At *that* point - the cookie dialogs should be displayed modaly for the CURRENT window.

Please do not mark this bug as a duplicate unless the bug has the same level of detail as this or has the exact same request. Lately (from what I've seen anyway) this bug has been the "hot spot" for these kinds of requests:  https://bugzilla.mozilla.org/show_bug.cgi?id=405239

I believe this is an error. That bug is asking for UI changes which I'm not advocating.  Instead I *SIMPLY* want the cookie dialogs to be modal *ON THE WINDOW THEY DERIVE FROM*.  

Hopefully whomever reads this will note the distinction between this - and that bug.

Thanks

Reproducible: Always

Steps to Reproduce:
1. go to any web site which contains numerous disparate links and do a google search, go to http://www.dzone.com/links/index.html or slashdot - any place that links to many places.
2. find a suitably slow internet connection (exacerbating the situation)
3. while holding the ctrl key, click on as many links in rapid succession as possible until firefox (annoyingly) begins stealing your focus
Actual Results:  
a modal displays and focus is stolen

Expected Results:  
"nothing" until i "activate" the window at which point i expect to be greeted by modal windows about the cookies on this site
bug 405239 is the right bug to dupe this one and I've read this bug
There is one issue with the cookie dialog and you have the same problem with it : a Tab/window in the background steals the focus and that is bug 405239

How "we" solve this may be different but you can add your suggestion in bug 405239 and that is enough.

marking as dupe of bug 405239 because it's the exact same issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 405239
And please don't file new bugs because you want more attention for an issue or if you want to get it fixed faster, you should read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
(Reporter)

Comment 3

10 years ago
(In reply to comment #1)
> bug 405239 is the right bug to dupe this one and I've read this bug
> There is one issue with the cookie dialog and you have the same problem with it
> : a Tab/window in the background steals the focus and that is bug 405239
> 
> How "we" solve this may be different but you can add your suggestion in bug
> 405239 and that is enough.
> 
> marking as dupe of bug 405239 because it's the exact same issue.
> 
> *** This bug has been marked as a duplicate of bug 405239 ***
thanks for your comment.  i didn't realize that it was only the "issue" that matters but rather the "issue plus solution".  

anyway thanks for your time
You need to log in before you can comment on or make changes to this bug.