'click' action on text accessible doesn't work in XML files

RESOLVED INVALID

Status

()

Core
Disability Access APIs
RESOLVED INVALID
9 years ago
6 years ago

People

(Reporter: surkov, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Open any XML file, 'click' action doesn't work on expanders ('-').
(Reporter)

Updated

9 years ago
Blocks: 461768
(Reporter)

Comment 1

9 years ago
another problem is placed 'click' attribute on html:body element doesn't force
text accessible to expose 'click' action because 'click' handler is registered
on document if I'm right but we don't achieve document when we traverse up from
this node (top most element is document element).
(Reporter)

Comment 2

9 years ago
we could navigate up through accessible tree and see if accessible expose actions (it sounds more correct because theoretically found action content may be not accessible and therefore nsLinkableAccessible won't work). But the problem is document accessible doesn't expose actions if 'click' attribute is placed on html:body or 'click' event handler is registered on document element.
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
>. But the
> problem is document accessible doesn't expose actions if 'click' attribute is
> placed on html:body or 'click' event handler is registered on document element.

I filed bug 461775
(Reporter)

Comment 4

9 years ago
If it doesn't make sense to expose actions on document accessible even there is registered 'click' event handler on document or document element then I think it doesn't prevent this bug to be fixed. All we need is to ensure action content of linkable accessible is accessible but if it's document element (which is not accessible) then we need to expose accessible actions manually (not via nsAccessible).
(Reporter)

Comment 5

6 years ago
no XML viewer nowdays. Closing.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.