Closed Bug 461767 Opened 11 years ago Closed 11 years ago

don't create nslinkableaccessible if 'click' event handler is registered

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: surkov, Assigned: surkov)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

actually it's enough to create hypertextacc because nsaccessible contains all we need to deal with actions.
Blocks: actiona11y
Attached patch patchSplinter Review
actually it should have been a part of bug 420863
Attachment #344892 - Flags: review?(aaronleventhal)
Attachment #344892 - Flags: review?(marco.zehe)
What does this fix?
I thought the point of nsLinkableAccessible is so that the descendants of either a link or clickable object has the same actions.
It does fix nothing. It's code clean up. nsLinkablAccessible is used for descendants of link or clickable accessibles or for clickable accessibles itself but it doesn't make sense to use it for clickable accessibles because nsAccessible has support of 'click' actions. As I mentioned it should be part of fix for the bug 420863 but I missed this point eventually.
Attachment #344892 - Flags: review?(aaronleventhal) → review+
Comment on attachment 344892 [details] [diff] [review]
patch

What happens with an ARIA link whose action can only be performed via an onclick or the like? We definitely want that exposed as a link.
(In reply to comment #4)
> (From update of attachment 344892 [details] [diff] [review])
> What happens with an ARIA link whose action can only be performed via an
> onclick or the like? We definitely want that exposed as a link.

Did you find a regression actually? Because we should expose it as a link. All like it was before I think.
Comment on attachment 344892 [details] [diff] [review]
patch

Ah OK, I see now that creating a link accessible is handled in a different function. Sorry, am just getting back into the saddle after my vacation. r=me
Attachment #344892 - Flags: review?(marco.zehe) → review+
http://hg.mozilla.org/mozilla-central/rev/5bd6876be7f2
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.