Closed Bug 461777 Opened 13 years ago Closed 13 years ago

Lack of support for OS X unified windows / drag-from-anywhere; default theme looks misleadingly unified

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 398928

People

(Reporter: gordeon, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

Firefox 3 Mac has a theme that seems to suggest a native unified window behavior where you can click-and-drag from anywhere, such as the status bar or the toolbar, but you can still only drag from the toolbar.  This means that Firefox still isn't using the OS X unified window.  Contrast this to Camino, which allows you to drag from any part of the browser chrome - status bar, toolbar, etc.

Reproducible: Always

Steps to Reproduce:
1. Click-and-drag either the buttons toolbar chrome or the status bar.  Unable to move the window.
2. Click-and-drag the title bar.  Able to move the window.
3. For comparison, repeat step 1 in Camino.  Able to move the window.
Will be in Fx 3.1
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 398928
You need to log in before you can comment on or make changes to this bug.