add "recently added/modified" or sort by modification time to exceptions dialogs

VERIFIED WONTFIX

Status

Camino Graveyard
Preferences
--
enhancement
VERIFIED WONTFIX
10 years ago
9 years ago

People

(Reporter: dan pritts, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.17) Gecko/20080915 Camino/1.6.4 (like Firefox/2.0.0.17)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.17) Gecko/20080915 Camino/1.6.4 (like Firefox/2.0.0.17)

It'd be really nice to be able to sort the exceptions lists for cookies,
popups, flashblock (if and when), etc., by "most recently added to list".  

Rationale:  occasionally with cookies, in particular, i click quickly and then
realize that i probably didn't want to allow a given cookie.  If i remember the
site name, i can go into the exceptions list and find it, but i don't always
remember.

Just "added during this session" would be good enough.  I can imagine that
being easier to implement, since you wouldn't have to add the modification date
to the data store.

Reproducible: Always

Comment 1

10 years ago
I'm not sure the data store has a provision for this sort of thing in the first place, at least in the case of cookies. (Flashblock would presumably be a case where we'd roll our own, and popup exceptions are already in our own format, so it wouldn't be as big a deal with those two.)

Dan, is this something the current cookie storage model supports?
Hardware: Macintosh → All
(Reporter)

Comment 2

10 years ago
This is what I was trying to get at when I said "you wouldn't have to add the modification date to the data store" - I was imagining that you'd need to extend the on-disk storage to support a modification date.  

That might be ideal (or might not, for other reasons; i haven't thought it through very hard).  "modified during this session" would be a fine 90% solution (to the problem i'd like to solve, anyway).

thanks to all for considering this & all your hard work on camino.

Comment 3

9 years ago
While I can see the potential usefulness, we don't want the cookie UI to become overly complex, and this would also take some weird plumbing to implement. I don't think this is something we ultimately want for Camino.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.