Strict DTD should warn or return something about invalid markups rather than simply ignore them

VERIFIED WONTFIX

Status

()

Core
HTML: Parser
P3
normal
VERIFIED WONTFIX
18 years ago
18 years ago

People

(Reporter: emk, Assigned: harishd)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Reproduceable: always.

Steps to reproduce:
1. Launch Mozilla.
2. Navigate to the following testcase.

Actual result:
Invalid markup is not displayed at all.

Expected result:
Error or warning should be reported or something should be displayed to notice 
invalid markups.

Occurs on:
I observed it using cvs build on Windows 2000.

If nothing displayed, user may not notice that document have some errors.
Even worse, user may miss the critical information just because of the author's 
simple mistake.
(Reporter)

Comment 1

18 years ago
Created attachment 11762 [details]
Testcase
(Assignee)

Comment 2

18 years ago
Working on it. Assigning to myself.
Assignee: rickg → harishd
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

18 years ago
Will be nice to have...but

This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this
is an error, that you or another known resource will be working on this bug,or 
if it blocks your work in some way -- please
attach your concern to the bug for reconsideration. 
(Assignee)

Updated

18 years ago
Target Milestone: --- → Future
See bug 48699 for how to send errors to the JS console.

Comment 5

18 years ago
Marking wontfix. We've decided to punt on strictDTD for 6.0.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 6

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.