Shortcut for "Hide Application" differ from the standard mac key combo

RESOLVED FIXED

Status

Mozilla Localizations
pt-PT / Portuguese
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: stefanh, Assigned: João Neves)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
(filing one bug per locale, please see the list below for your locale)


The mac shortcut keys for hiding the current application is a fairly standardized shortcut combo (accel+H). The same goes for "Hide all other applications" (accel+alt+H). Doing a mxr search for "hideThisAppCmdMac.commandkey" in l10n, shows quite a few locales that has different keys. Note that for some locales there might be exceptions (ar and el maybe?), but I think most of the locales should use "H". Note also that the keys for opening preferences and quitting the application are also standardized on mac afaik.


Summary: (locale and directory)

af - browser
ar - browser
bg - browser
da - browser
de - calendar
el - browser
es-AR - mail
et - calendar
fr - mail, calendar
fy-NL = browser, mail, calendar
id - mail
is - calendar
it - mail, calendar
ku - browser
nb-NO and nn-NO - mail, calendar
nl - mail, calendar
pl - mail, calendar
pt-PT - browser, mail, calendar
sr - mail
tr - mail, calendar
uk - calendar

Summary:

The following keys are standardized:

hideThisAppCmdMac.commandkey (accel+H)
hideOtherAppsCmdMac.commandkey (accel+alt+H)
preferencesCmdMac.commandkey (accel+,"
"Quit" commandkey (doesn't have the entity handy atm, the keys are accel+Q).

Note: I haven't checked suite/ yet because the entities are named different.
(Reporter)

Comment 1

9 years ago
ouch,
> preferencesCmdMac.commandkey (accel+,"

should be accel+,
(Reporter)

Comment 2

9 years ago
> The following keys are standardized:
> 
> hideThisAppCmdMac.commandkey (accel+H)
> hideOtherAppsCmdMac.commandkey (accel+alt+H)
> preferencesCmdMac.commandkey (accel+,"
> "Quit" commandkey (doesn't have the entity handy atm, the keys are accel+Q).

I think I might have added some confusion with the above lines. I was actually talking about the key combo that you press and not just the commandkey. I other words, I don't mean that "hideThisAppCmdMac.commandkey (accel+H)" should be "accel+H", it should of course be "H" and "hideThisAppCmdMac.modifiers" should be "accel".

So, it should look like this:

<!ENTITY preferencesCmdMac.commandkey   ",">
<!ENTITY preferencesCmdMac.modifiers    "accel">
<!ENTITY hideThisAppCmdMac.commandkey   "H">
<!ENTITY hideThisAppCmdMac.modifiers    "accel">
<!ENTITY hideOtherAppsCmdMac.commandkey "H">
<!ENTITY hideOtherAppsCmdMac.modifiers  "accel,alt">

And the Quit commandkey should be "Q", and if there's a corresponding .modifiers entity it should be "accel" (IIRC there is a .modifiers entity for Quit in suite/, but I'm unsure if the other apps have it)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 440327
You need to log in before you can comment on or make changes to this bug.