Closed Bug 461944 Opened 11 years ago Closed 8 years ago

Selected event in unifinder is not highlighted in calendar view

Categories

(Calendar :: Calendar Views, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: andreas.treumann, Assigned: martinschroeder)

Details

(Keywords: regression)

Attachments

(1 file)

STEPS TO REPRODUCE:
===================

- select an event in the unifinder

RESULT:
=======

- the selected event is not highlighted in the calendar view

EXPECTED RESULT:
================

- the selected event should be highlighted in the calendar view

REPRODUCIBLE:
=============

- always

Same behavior vice versa.

Last build without this issue: 20081022, first with this bug: 20081023.
Fallout from my last checkin... fix to come.
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
Bug 452381 was reopened because of this regression. See Bug 452381 comment #5 ff.
Attached patch Patch v1Splinter Review
Attachment #345262 - Flags: review?(philipp)
Summary: selecected event in unifinder is not highlighted in calendar view → Selected event in unifinder is not highlighted in calendar view
Comment on attachment 345262 [details] [diff] [review]
Patch v1

Looks good, r=philipp
Attachment #345262 - Flags: review?(philipp) → review+
Keywords: checkin-needed
Przemyslaw, please do not set the checkin-needed keyword for patches from people having checkin rights.
Keywords: checkin-needed
Sorry. Assuming the author would forget to add it can it be checked somewhere if he has them ?
or I will just use them on my own bugs...
Przemyslaw, there is no way to check who has those rights, so just set them on your own bugs.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/914b9beed0c3>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
-> VERIFIED

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081103 Lightning/1.0pre (build 20081103050206) Shredder/3.0b1pre
Status: RESOLVED → VERIFIED
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
I'm still experiencing part of this in actual trunk builds.

in Multiweek- & Month-view, if you select a single event in unifinder, only the respective day gets highlighted, not the event.
if you select more than one, it works as expected.

Reopening this one for now, but I can also file a new bug if desired.
I'll have a look into this soon.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
First analysis showed that if a single event is selected in unifinder with month-view shown, relayout is triggered.
The relayout Method does not take into account selected items, so the box is not highlighted.
An easy fix would be:
  if (this.calendarView.mSelectedItems.indexOf(aItem) != -1) {
      box.setAttribute("selected", true);
  }
in the relayout method.

Since in Day- & MultiDay-view, the selection is even retained if switched to next day/week and back and in Month-view with this fix it is not, I'm not sure yet, if this is the way to do it.
I Will have to get more understanding of the selection-stuff in lightning.
Just wondering:
do we really want to keep items selected, that are not in the current view?
This might en in deleting items you don't want to delete without confirmation and without seeing them disappear - thus unnoticed.
What is with items that are visible in the unifinder but not in a view?
One example:
1. go to week view
2. select an item in the unifinder
3. select another item, that is not in the current view.
4. change focus to the view by clicking the forward button
5. change back to the original week with the back button
6. selection in the unifinder is barely noticeable (at least with the current standard theme in ubuntu, windows7 is better)
7. hit delete

Outcome: both items are deleted, one may well go unnoticed.

Maybe we should rethink the way these selections work.
At least it should be more clear, which field has the focus and hitting delete should only delete the items in the focused view.
Any comments?
Keywords: uiwanted
(In reply to Markus Adrario [:Taraman] from comment #10)
> Reopening this one for now, but I can also file a new bug if desired.
> I'll have a look into this soon.

I think filing a new bug report is more appropriate.
done.

see Bug 723436
Status: REOPENED → RESOLVED
Closed: 11 years ago8 years ago
Resolution: --- → FIXED
Keywords: uiwanted
You need to log in before you can comment on or make changes to this bug.