Ctrl-Tab panel is sticky when focusing another application while panel is open

VERIFIED FIXED in Firefox 3.1b2

Status

()

defect
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression})

Trunk
Firefox 3.1b2
x86
Windows Vista
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081027 Minefield/3.1b2pre (.NET CLR 3.5.30729) ID:20081027034233

Opening the Ctrl-Tab panel, holding the Ctrl key and switching to another application lets the panel be sticky. Means it's not closed until you click on a tab preview. In between you can work with the browser in a normal way but with the panel in front.

Steps to reproduce:
1. Open at least 3 tabs
2. Press Ctrl+Tab and hold Ctrl key pressed
3. Use the mouse to select another application so Firefox loses focus
=> Ctrl-Tab panel isn't closed

4. Return to Firefox and create, move or destroy tabs or do whatever you want
=> Ctrl-Tab panel isn't closed

5. Click on any of the tab previews
=> Ctrl-Tab panel is closed and selected tab is openend.

I believe that we should close the panel immediately when the user switches to another application. The panel shouldn't stay in a top z-index position which blocks the UI in terms of visibility.

Not tested on other platforms yet.
Blocks: 451300
No longer blocks: 395980
Depends on: 460560
Dao, this can also be seen on XP. Does it really block bug 451300 because that bug only changed CSS for Aero?
(In reply to comment #1)
> Does it really block bug 451300

Yes.
Keywords: regression
Duplicate of this bug: 463220
Flags: wanted-firefox3.1?
Flags: blocking-firefox3.1?
Depends on: 457997
No longer depends on: 460560
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b2
Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081111 Minefield/3.1b2pre ID:20081111032821
Status: RESOLVED → VERIFIED
Flags: wanted-firefox3.1?
Flags: blocking-firefox3.1?
You need to log in before you can comment on or make changes to this bug.