If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Category is not saved on event modification (only on event creation)

VERIFIED DUPLICATE of bug 460041

Status

Calendar
Provider: GData
--
major
VERIFIED DUPLICATE of bug 460041
9 years ago
6 years ago

People

(Reporter: Cyril Roussillon, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008100612 Gentoo Firefox/3.0.3
Build Identifier: GData 0.5.1, Lightning 0.9, Thunderbird 2.0.0.17

If I create an event with a category, it works ok. Then if I modify the event and change anything (even not related to category, such as title, description, ...) the category disappears. There is no way to have a category back after having modified the event.

According to logs, the category is not written in the XML file when the event is modified :

* Event creation with category :

Logging object...
action: Setting Upload Data:
content: application/atom+xml; charset=UTF-8
data: <entry xmlns:gd="http://schemas.google.com/g/2005"
xmlns:gCal="http://schemas.google.com/gCal/2005" xmlns="http://www.w3.org/2005/Atom">
  <category scheme="http://schemas.google.com/g/2005#kind" term="http://schemas.google.com/g/2005#event"/>
  <title type="text">task creation with category</title>
  <content type="text"/>
  <author>
    <name>myname</name>
    <email>myemail</email>
  </author>
  <gd:transparency value="http://schemas.google.com/g/2005#event.opaque"/>
  <gd:eventStatus value="http://schemas.google.com/g/2005#event.confirmed"/>
  <gd:where valueString=""/>
  <gCal:sendEventNotifications value="true"/>
  <gd:when startTime="2008-11-01T11:00:00+01:00" endTime="2008-11-01T12:00:00+01:00"/>
  <gd:visibility value="http://schemas.google.com/g/2005#event.default"/>
  <gd:extendedProperty name="X-MOZ-CATEGORIES" value="mandatory-regular"/>
  <gCal:sequence value="0"/>
  <gCal:uid value=""/>
</entry>
End object

* Event modification (same event with category, just changed title) :

Logging object...
action: Setting Upload Data:
content: application/atom+xml; charset=UTF-8
data: <entry xmlns:gd="http://schemas.google.com/g/2005"
xmlns:gCal="http://schemas.google.com/gCal/2005" xmlns="http://www.w3.org/2005/Atom">
  <category scheme="http://schemas.google.com/g/2005#kind" term="http://schemas.google.com/g/2005#event"/>
  <title type="text">task creation with category - just changed title</title>
  <content type="text"/>
  <author>
    <name>myname</name>
    <email>myemail</email>
  </author>
  <gd:transparency value="http://schemas.google.com/g/2005#event.opaque"/>
  <gd:eventStatus value="http://schemas.google.com/g/2005#event.confirmed"/>
  <gd:where valueString=""/>
  <gd:who email="gu258a1l87eb2v09ij3bjb05mg@group.calendar.google.com" rel="http://schemas.google.com/g/2005#event.organizer" valueString="Pro"/>
  <gCal:sendEventNotifications value="true"/>
  <gd:when startTime="2008-11-01T11:00:00+01:00" endTime="2008-11-01T12:00:00+01:00"/>
  <gd:visibility value="http://schemas.google.com/g/2005#event.default"/>
  <gCal:sequence value="0"/>
  <gCal:uid value="3fnu1gbmm3pk1sie6i5lo6dq18"/>
</entry>
End object


Now <gd:extendedProperty name="X-MOZ-CATEGORIES" is missing...


Reproducible: Always

Steps to Reproduce:
1.create event with category
2.modify event
3.
Actual Results:  
category disappears, even if not manually changed

Expected Results:  
category remains
(Reporter)

Updated

9 years ago
Version: unspecified → Lightning 0.9
(Reporter)

Updated

9 years ago
Version: Lightning 0.9 → unspecified
(Reporter)

Comment 1

9 years ago
After further investigation:

* At event creation:
aItem.organizer: null
aItem.calendar.googleCalendarName: undefined

* At event modification:
aItem.organizer: Pro <gu258a1l87eb2v09ij3bjb05mg@group.calendar.google.com>
aItem.organizer.id: mailto:gu258a1l87eb2v09ij3bjb05mg@group.calendar.google.com
aItem.calendar.googleCalendarName: undefined

* With:

calGoogleUtils.js:361,ItemToXMLEntry
var selfIsOrganizer = (!aItem.organizer ||
                            aItem.organizer.id == "mailto:" + aItem.calendar.googleCalendarName);
calGoogleUtils.js:365,addExtendedProperty
if (!selfIsOrganizer || !aValue) return;

So extended properties cannot be written at task modification. Now why is aItem.calendar.googleCalendarName undefined ?

Yet the "function" :

calGoogleCalendar.js:76
get googleCalendarName cGC_getGoogleCalendarName() {

returns the right name.

But in:

calGoogleCalendar.js,365
modifyItem: function cGC_modifyItem(aNewItem, aOldItem, aListener) {

we have:

aOldItem.calendar.googleCalendarName: undefined
aNewItem.calendar.googleCalendarName: undefined

But I don't understand from where is called this modifyItem function (I don't know a lot about javascript).
This might be a core problem: see related bug 460041

Comment 3

9 years ago
Cyril, is this issue still valid after bug 460041 is fixed verified? Please try to reproduce this issue with the newest sunbird or lightning build, thanks.

Comment 4

9 years ago
No response from reporter since nearly one month. Change status to 'duplicate fixed' by comment #2/#3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 460041

Updated

9 years ago
Status: RESOLVED → VERIFIED

Comment 5

6 years ago
I found this old bug and have this problem...
Everytime I try to change an event from google calender (changing the category or adding an alarm) this is not stored.
It is only possible to create a new event with all informations and delete the old one.

Comment 6

6 years ago
Sorry, I created a new Calender and now it is working fine!
No bug anymore....
You need to log in before you can comment on or make changes to this bug.