[MARGIN-C]<TABLE><FONT> problem

RESOLVED WONTFIX

Status

()

Core
Layout
P3
normal
RESOLVED WONTFIX
18 years ago
17 years ago

People

(Reporter: mats, Assigned: Chris Waterson)

Tracking

({testcase})

Trunk
mozilla1.0
x86
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
STEPS TO REPRODUCE:
1. goto http://www.news.com/
2. compare vertical space between "More news from around the Web" and first
   bullet below in NS4/IE5/Mozilla.

ACTUAL RESULTS:
Mozilla displays to much vertical space before the list compared with NS4/IE5 ?
(case 1. in the testcase) 

BROWSERS/PLATFORMS tested:
Mozilla nightly build 2000-07-20-08, Communicator 4.72 and IE5.00
all on Windows 98 SE.

ADDITIONAL INFO:
Looks similar to bug 5749.
Will attach testcase and snapshot.
(Reporter)

Comment 1

18 years ago
Created attachment 11772 [details]
Testcase
(Reporter)

Comment 2

18 years ago
Created attachment 11773 [details]
Snapshot of the 3 browsers with testcase above
(Reporter)

Updated

18 years ago
Keywords: 4xp, testcase
(Reporter)

Updated

18 years ago
Keywords: top100
The issue in testcase (1) is a duplicate of bug 44264 (and maybe also an {ib}
bug I gave to waterson).

I'd rather leave (3) and (4) as they are right now.  Do we need a quirk for that
too?  Maybe...

Assigning to myself since it's a vertical margin issue and I'm hoping to work on
those soon.
Assignee: clayton → dbaron
Summary: <TABLE><FONT> problem → [MARGIN-C]<TABLE><FONT> problem
Giving margin collapsing bugs that I have not fixed to buster.
Assignee: dbaron → buster

Comment 5

17 years ago
relatively minor margin issue.  marking future.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 6

17 years ago
moving to m0.9.1
Target Milestone: Future → mozilla0.9.1
(Assignee)

Comment 7

17 years ago
taking; retargeting to 0.9.2
Assignee: buster → waterson
Status: ASSIGNED → NEW
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla1.0
(Reporter)

Comment 8

17 years ago
Removing URL http://www.news.com/ since it does not have this problem anymore.
In the testcase, case 1. is a dup of bug 33784, case 2. is correctly displayed.
case 3 and 4 does not collapse margins because of the border (which is correct
according to CSS2). So the question is, (for case 3 and 4) do we want to do margin
collapsing even in the presens of borders in quirks mode?
Nav4.7 and IE5 seems to do that but there seems to be few sites depending on this,
since there haven't been a dupe in over a year on this bug.
If I hear no objections I will close this as dupe of 33784, regarding cases 3 and 4
as INVALID/WONTFIX.
Keywords: top100
(Assignee)

Comment 9

17 years ago
Sounds reasonable. cc'ing hixie for moral support.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
I like it!
You need to log in before you can comment on or make changes to this bug.