3.0b1pre ignores IMAP expunge replies

RESOLVED DUPLICATE of bug 420115

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 420115
9 years ago
9 years ago

People

(Reporter: Andrey Cherezov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ru; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; ru; rv:1.9.1b2pre) Gecko/20081026 Shredder/3.0b1pre

Sometimes after EXPUNGE command - messages, marked as deleted, remains in the folder, not disappers. Checked the log - server responce is correct, but these messages isn't deleted in the TB list window.
This problem with two different IMAP servers - under Linux and Windows.

Version: Mozilla/5.0 (Windows; U; Windows NT 6.0; ru; rv:1.9.1b2pre) Gecko/20081026 Shredder/3.0b1pre

Log (server - Courier IMAP under Linux):
...
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: 21 OK IDLE completed
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:ProcessCurrentURL: entering
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:ProcessCurrentURL:imap://cherezov@imap.enet.ru:144/Expunge%3E.INBOX:  = currentUrl
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:SendData: 22 expunge
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 28 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=14 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 29 EXPUNGE
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=13 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 28 EXISTS
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=12 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: * 0 RECENT
5136[3efbed0]: ReadNextLine [stream=61c6a50 nb=25 needmore=0]
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:CreateNewLineFromSocket: 22 OK EXPUNGE completed
5136[3efbed0]: 3a7c780:imap.enet.ru:S-INBOX:SendData: 23 getquotaroot "INBOX"
...


Reproducible: Always

Steps to Reproduce:
1. Delete or move few messages (becomes marked to delete)
2. Expunge
3. Nothing changes in client window
Actual Results:  
Nothing changes in the client window

Expected Results:  
Messages, marked as deleted, should disappear.
(Reporter)

Comment 1

9 years ago
If after that I receive new messages and delete them, then expunge them - they are disappears as expected. But 'old' expunged messages remains in the list till the next Shredder restart.

Comment 2

9 years ago
do you know if your servers support condstore?
(Reporter)

Comment 3

9 years ago
There is no support for CONDSTORE in my Windows IMAP server, and there no CONDSTORE keyword in the CAPABILITY command response at the CourierIMAP on Linux.

Comment 4

9 years ago
This looks like bug 420115 - which I think isn't a regression per se, but indeed it's much worse on trunk...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 420115
You need to log in before you can comment on or make changes to this bug.