add nsIArray support to mailnews/base/util/iteratorUtils.jsm

RESOLVED FIXED in Thunderbird 12.0

Status

MailNews Core
Backend
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: Bienvenu, Unassigned)

Tracking

Trunk
Thunderbird 12.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 698925])

(Reporter)

Description

9 years ago
spun-off from bug 418490, toXPCOMIterator should handle nsIArray as well.
(Reporter)

Comment 1

9 years ago
I'm not sure this is needed - the js code needs to create an nsIMutableArray in order to put things in the array, and if you pass in the nsIMutableArray interface, you can pass the result to callers expecting an nsIArray.

Comment 2

9 years ago
The point is that the JS can create a normal array and then use the utility to convert it to an nsIArray, and can also use the utility to iterate an nsIArray.
(Reporter)

Comment 3

9 years ago
iterating an nsIArray makes sense, but converting it to an nsIArray would mean creating an nsIMutableArray, and then I guess QI'ing that to an nsIArray, right?

Comment 4

9 years ago
nsIMutableArray inherits from nsIArray last time I looked.
Depends on: 418490

Comment 5

5 years ago
Fixed in bug 698925.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Summary: add nsIArray support to mailnews/base/utils/nsIteratorUtils.jsm → add nsIArray support to mailnews/base/util/iteratorUtils.jsm
Duplicate of bug: 698925

Updated

5 years ago
Depends on: 698925
Resolution: DUPLICATE → FIXED
Whiteboard: [fixed by bug 698925]
Target Milestone: --- → Thunderbird 12.0
You need to log in before you can comment on or make changes to this bug.