choosing "browse" button to find a file to upload achieves dialogue box to find file 75% chance of successfully selecting file after hitting "open"

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
minor
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: philozeppelin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081027 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081027 Minefield/3.1b2pre

Hitting "open" after getting the browser to choose your file results in hang. The dialogue box or file browser stays in place and the filepath does not populate on the main page. Luckily Minefield does not crash or require force quitting. Double-clicking the main page results in the dialogue box/file browser disappearing and then you can try again.

Observed this on only one other site and it is unclear if this is only an issue with this build or with the sites (same issue observed in WebKit).

Reproducible: Sometimes

Steps to Reproduce:
1. Under "Upload Graphic" hit the button that says "Browse..."
2. Select any small graphic (tried with a JPEG and a GIF)
3. Hit button "open"

75% chance of success.
Actual Results:  
1 in 4 attempts observed the reported behavior. WebKit has slightly higher rate of success.

Expected Results:  
The software should be populating the filepath of the chosen image in the field on the main page.

The frequency may change based on selecting one image and then changing to another prior to hitting "open"

Minefield is the fastest browser I've used yet! Keep up the amazing work. This "bug," if it can even be called that, is trivial and does not tarnish the stellar job that has been accomplished with this browser.

Many Thanks!

Comment 1

10 years ago
This is a system dialog, and you say this also happens in WebKit, so I think it's pretty unlikely that this is a Firefox bug.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.