If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

On Today Pane Events and Tasks view, a right click on the last items in the list, deletes the tasks

RESOLVED INVALID

Status

Calendar
Lightning Only
RESOLVED INVALID
9 years ago
8 years ago

People

(Reporter: Viorel Lazar, Unassigned)

Tracking

Lightning 0.9
x86
Linux

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.17) Gecko/20080922 SUSE/1.1.12-0.1 SeaMonkey/1.1.12
Build Identifier: Mozilla Thunderbird version 2.0.0.17 (20080922) - Lightning- build 2008091718

If on the today pane you switch to Events and Tasks or the Tasks view if you have enough  tasks to reach the bottom of the screen, a right click on a task causes the task to be deleted. This problem is because the context menu is no longer displayed from top (mouse cursor) downwards , but from cursor position (bottom) upwards. This causes that the option on the context menu on witch the mouse is hovering is "Delete Task" and if you just make a right click on those tasks, they instantly disappear forever (the same thing happens with events too). However , please insert a Delete confirmation dialog before removing a task or event ... it is very important to have this in a future update (i don't want to delete tasks ... i just mark them as done, so it should ask me if I'm shore).

Reproducible: Always

Steps to Reproduce:
1.add tasks until they reach the bottom of the screen or move the window so that the context menu needs repositioning because of the bottom and right screen limits
2.right click on the bottom task/event
3.optional, push the right button of the mouse and release it 3 seconds later to better understand what happens
Actual Results:  
it deleted my tasks

Expected Results:  
just display the context menu and in case i click on the delete item to ask me if i'm shore i want to delete it
(Reporter)

Updated

9 years ago
Version: unspecified → Lightning 0.9

Comment 1

9 years ago
Hint: Switch to Calendar Mode or Task Mode and call Edit > Undo if you accidentally deleted a task or event.
Voting for WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → INVALID
You need to log in before you can comment on or make changes to this bug.