Closed Bug 462132 Opened 11 years ago Closed 11 years ago

[sk] Add Azet.sk mailto: protocol handler

Categories

(Mozilla Localizations :: sk / Slovak, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wladow, Assigned: wladow)

Details

(Keywords: verified1.9.0.5)

Attachments

(1 file)

Azet.sk has just implemented mailto: protocol handler support for their webmail and because it's the most popular service in Slovakia we would like to add it to sk builds.

Name: Azet Mail
URL: http://emailnew.azet.sk/MailSend.phtml?url=%s

Contact person: Zuzana Chuda <chuda@firma.azet.sk>

Test suite tracker: http://spreadsheets.google.com/pub?key=pzJbUvwmY-2KB2zYYEOaNMg
(failing tests are being worked on)
Attachment #345264 - Flags: review?(stas)
After talking to stas regarding to test suite:
The last possibly failing test from ctalbert's test suite is the test 5. It's testing an invalid link mailto:addr1@foo.com?cc=addr2@foo.com?body=foo
Azet currently accepts TO and CC from the link and drops body param, what is a good implementation I think, even better than f.e. Gmail uses (Gmail uses 'addr2@foo.com?body=foo' as a CC).

ctalbert's comment for this test: "Invalid mailto URL - this should not work. Ideally there should be some sort of error message caused by this URL. Very few implementations tend to create such a message though."

I don't know what RFC says, but azet's implementation sounds logically to me.
Axel, Clint, what do you think about comment 1?

Vlado: does it do what would be logical when the URL is:
mailto:addr1@foo.com?body=foo?cc=addr2@foo.com
i.e. ignores CC and puts "foo" in the message body?

Or, what should actually happen if the URL is:
mailto:addr1@foo.com?cc=addr2@foo.com?body=foo&subject=bar
(In reply to comment #2)
> Axel, Clint, what do you think about comment 1?
> 
> Vlado: does it do what would be logical when the URL is:
> mailto:addr1@foo.com?body=foo?cc=addr2@foo.com
> i.e. ignores CC and puts "foo" in the message body?
yes

> 
> Or, what should actually happen if the URL is:
> mailto:addr1@foo.com?cc=addr2@foo.com?body=foo&subject=bar
azet is currently ignoring everything after the second '?' char, because that's the invalid part.
(In reply to comment #3)
> (In reply to comment #2)
> > Axel, Clint, what do you think about comment 1?
> > 
> > Vlado: does it do what would be logical when the URL is:
> > mailto:addr1@foo.com?body=foo?cc=addr2@foo.com
> > i.e. ignores CC and puts "foo" in the message body?
> yes
> 
> > 
> > Or, what should actually happen if the URL is:
> > mailto:addr1@foo.com?cc=addr2@foo.com?body=foo&subject=bar
> azet is currently ignoring everything after the second '?' char, because that's
> the invalid part.

I think this implementation (to ignore everything after that second question mark) is a proper implementation.  If the second question mark is properly escaped, then it should *not* ignore the rest of the line.  Does it do that?
When escaped in above url, azet ignores body param and accepts subject. So I think this is the correct behaviour.
Comment on attachment 345264 [details] [diff] [review]
add azet mailto handler

This looks good then! :) Clint, thanks for the comment, Vlado, thanks for all the work verifying all test cases.

r=me. Please land this patch in hg. For CVS, I'm asking for approval1.9.0.5.

One more thing:

>+gecko.handlerService.schemes.mailto.2.name=Azet Mail
We won't be able to change the name, so just checking if "Azet Mail" is what you want.
Attachment #345264 - Flags: review?(stas)
Attachment #345264 - Flags: review+
Attachment #345264 - Flags: approval1.9.0.5?
(In reply to comment #6)
Thank you.

> >+gecko.handlerService.schemes.mailto.2.name=Azet Mail
> We won't be able to change the name, so just checking if "Azet Mail" is what
> you want.
Yes, that's what Azet folks proposed.
Vlado, have you had a chance to verify this yet? Can we mark this bug as fixed?
Yes, works fine with hg builds, I'm just waiting for 
Pike's 'go' signal for landing to cvs, then I'll mark this fixed.
Comment on attachment 345264 [details] [diff] [review]
add azet mailto handler

a=me for 3.0.5. Please land this with a check-in comment referencing this bug, stas' review and my approval. Something like "bug 462132, add azet.sk mailto protocol handler, r=stas, a=l10n@mozilla.com" would do.

Please use the fixed1.9.0.5 and verified1.9.0.5 keywords to track landing and testing.
Attachment #345264 - Flags: approval1.9.0.5? → approval1.9.0.5+
Checked in: region.properties, rev. 1.9
-> fixed
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: fixed1.9.0.5
Resolution: --- → FIXED
Verified with 
Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.0.5pre) Gecko/2008112406 GranParadiso/3.0.5pre
and
Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.1b3pre) Gecko/20081126 Minefield/3.1b3pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.