JS crash running chrome mochitests on Mac OS X 10.5.5

RESOLVED DUPLICATE of bug 462186

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 462186
10 years ago
10 years ago

People

(Reporter: Josh Aas, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
I was running chrome mochitests (python runtests.py --chrome) on Mac OS X 10.5.5 with a debug build of Minefield and got a crash, the top few frames of which look like this:

Thread 0 Crashed:
0   libmozjs.dylib                	0x002b1569 JS_Assert + 67 (jsutil.cpp:63)
1   libmozjs.dylib                	0x00268860 ReconstructPCStack(JSContext*, JSScript*, unsigned char*, unsigned char**) + 940
2   libmozjs.dylib                	0x00268d63 DecompileExpression(JSContext*, JSScript*, JSFunction*, unsigned char*) + 699
3   libmozjs.dylib                	0x002782b2 js_DecompileValueGenerator + 612 (jsopcode.cpp:4974)
(Reporter)

Comment 1

10 years ago
Created attachment 345414 [details]
full stack
(Reporter)

Comment 2

10 years ago
This was near the end of the terminal output:

Assertion failure: OBJ_BLOCK_DEPTH(cx, obj) == pcdepth, at /Users/josh/src/mozilla/ff_191_debug/js/src/jsopcode.cpp:5200
ERROR FAIL Exited with code 5 during test run
WARNING: nsExceptionService ignoring thread destruction after shutdown: file /Users/josh/src/mozilla/ff_191_debug/xpcom/base/nsExceptionService.cpp, line 194
(Reporter)

Comment 3

10 years ago
The particular test that crashes is:

toolkit/mozapps/downloads/tests/chrome/test_multi_select.xul

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462186
You need to log in before you can comment on or make changes to this bug.