If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

line-height property error: leading should be split equally above and below the the textline in a paragraph.

VERIFIED INVALID

Status

()

Core
Layout
P3
major
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Peter Poirier, Assigned: clayton)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (Win95; I ;Nav)
BuildID:    2000033112

When line-height is specified for a paragraph, the leading (line-height minus 
text height) should be split equally, with half the white space above the line & 
half below it.  In NAV6, it seems an entire line-height's worth of white space 
is placed above the first line, thus positioning the entire paragraph 
incorrectly.  Opera does this wrong in the same way, but it worked almost 
correctly in NAV/Communicator 4.x (I think 4.x products may not have included 
internal leading when calculating the text-height, but it was mostly correct).

Reproducible: Always
Steps to Reproduce:
1.look at the test case
2.
3.

Actual Results:  					

Expected Results:
This bug has nothing to do with line-height.  The problem is that P, by default,
has a 1em margin on top and bottom.  4.x was ignoring this margin.  Mozilla is,
correctly, not ignoring it, and neither is Opera.  If you add p { margin: 0; }
to the test, it works.  Marking bug INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 2

17 years ago
Source code problem not ours. Marking as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.