"Linux comm-central dep unit test" is orange since a few days

RESOLVED FIXED in seamonkey2.0a2

Status

--
major
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: sgautherie, Unassigned)

Tracking

({crash})

Trunk
seamonkey2.0a2
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
It looks like this box has/shows a few test regressions/crashes on top of one another.

***

The latest issue, which is a crash:

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225299735.1225304709.19189.gz
Linux comm-central dep unit test on 2008/10/29 10:02:15
http://hg.mozilla.org/mozilla-central/rev/a62df7b5b9bb
mochitest  FAIL

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225293787.1225300088.6469.gz
Linux comm-central dep unit test on 2008/10/29 08:23:07
http://hg.mozilla.org/mozilla-central/rev/3dbb3095c8a9
mochitest  63543/5/1500

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-10-29+07%3A23%3A07&enddate=2008-10-29+10%3A03%3A48
This one would be http://hg.mozilla.org/mozilla-central/rev/a62df7b5b9bb !?

...

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225270269.1225276482.12112.gz
Linux comm-central dep unit test on 2008/10/29 01:51:09
http://hg.mozilla.org/mozilla-central/rev/5bd6876be7f2
mochitest 63542/5/1500

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225266818.1225270622.28188.gz
Linux comm-central dep unit test on 2008/10/29 00:53:38
http://hg.mozilla.org/mozilla-central/rev/ce5e8d5a268d
mochitest FAIL

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-10-29+00%3A35%3A58&enddate=2008-10-29+01%3A56%3A18
This one would be one of the 3 "accessible" again.!?.

...

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225206448.1225210470.18505.gz
Linux comm-central dep unit test on 2008/10/28 08:07:28
http://hg.mozilla.org/comm-central/rev/aa3428e96c98
mochitest FAIL

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225202804.1225206811.7891.gz
Linux comm-central dep unit test on 2008/10/28 07:06:44
http://hg.mozilla.org/comm-central/rev/e104cc413c8e
green

http://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-10-28+06%3A55%3A14&enddate=2008-10-28+08%3A13%3A11
The less unlikely would be http://hg.mozilla.org/comm-central/rev/6442d905c13d !?

***

Let's fix this crash first,
then we'll see about the previous/underlying failures.

NB: It would be great if someone with Linux could reproduce (any of) the crash/failures.

PS: KaiRo, maybe it could help to manually run one build with the revs from when it was green, to be sure it's not the box itself which is at fault.!?.
Flags: blocking-seamonkey2.0a2?

Comment 1

10 years ago
The most recent cycle didn't crash, either the crash is intermittent or it might be related to bug 458058
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> The most recent cycle didn't crash, either the crash is intermittent or it
> might be related to bug 458058

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225353248.1225357417.5904.gz
Linux comm-central dep unit test on 2008/10/30 00:54:08
(rev:5709136d4b9c)
m-c:c5a47d50ea36
mochitest FAIL

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225357061.1225363406.20866.gz
Linux comm-central dep unit test on 2008/10/30 01:57:41
(rev:dc4edb5fe229)
m-c:03288ea8c289
mochitest 63544/5/1500

Bug 458058 fix is in this timeframe and would be consistent with previous diagnosis of being related to "accessible" :-)

*****

Now, the 2 other issues to look at:
{
mochitest 63551/5/1500
chrome 4915/8/2
}
Depends on: 458058

Comment 3

10 years ago
bug 458058 was only checked in this morning. It fixes a crash bug in a1y code which doesn't have any mochitests running at all yet.
Do the tinderboxes have accessibility enabled on Linux at all? If not, then there's no way bug 458058 could have caused these I think.
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)

I fully agree ... yet, I have no better clue about what happened :-|
(Reporter)

Comment 5

10 years ago
(In reply to comment #2)

> mochitest 63551/5/1500

{
*** 68907 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_menubar.xul | Test timed out.
*** 68910 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_menuchecks.xul | Test timed out.
*** 69129 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_popup_attribute.xul | Test timed out.
*** 69132 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_popup_button.xul | Test timed out.
*** 69133 ERROR TEST-UNEXPECTED-FAIL | /tests/toolkit/content/tests/widgets/test_popup_button.xul | Too many test timeouts, giving up.
}

Finding a "narrow" regression timeframe for this one will be hard, as it was "shadowed" by the crash.

*****

> chrome 4915/8/2

{
*** 4952 INFO Error: Unable to restore focus, expect failures and timeouts.
*** 4955 INFO Error: Unable to restore focus, expect failures and timeouts.
*** 4956 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_bug360437.xul | Test timed out.
*** 4959 INFO Error: Unable to restore focus, expect failures and timeouts.
*** 4963 INFO Error: Unable to restore focus, expect failures and timeouts.
*** 4967 INFO Error: Unable to restore focus, expect failures and timeouts.
*** 4969 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_findbar.xul | testNormalFind: find field is not focused
*** 4970 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_findbar.xul | testNormalFind: failed to find 'text tes'
*** 4977 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_findbar.xul | Case Sensitive label was not correctly updated
*** 4978 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_findbar.xul | Test timed out.
*** 4981 INFO Error: Unable to restore focus, expect failures and timeouts.
*** 4982 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_keys.xul | Test timed out.
*** 4985 INFO Error: Unable to restore focus, expect failures and timeouts.
*** 4986 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | Test timed out.
*** 4987 ERROR TEST-UNEXPECTED-FAIL | chrome://mochikit/content/chrome/toolkit/content/tests/chrome/test_largemenu.xul | Too many test timeouts, giving up.
}

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225248194.1225251334.3024.gz
Linux comm-central dep unit test on 2008/10/28 19:43:14
rev:ea049a1644bd
m-c:0065966a40ac
chrome 5297/0/29

... (in-between builds crashed due to bug 452205 :-()

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225259773.1225263700.6747.gz
Linux comm-central dep unit test on 2008/10/28 22:56:13
rev:6be903922c66
m-c:1c977c8c9c67
chrome 4915/8/2

http://hg.mozilla.org/comm-central/pushloghtml?startdate=2008-10-28+19%3A38%3A06&enddate=2008-10-28+20%3A54%3A05
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-10-28+19%3A48%3A34&enddate=2008-10-28+22%3A24%3A05
I'm not sure which checkin to blame :-/

*****

Can someone reproduce these ?
(Reporter)

Comment 6

10 years ago
Crash is back :-(

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225403978.1225411413.22699.gz
Linux comm-central dep unit test on 2008/10/30 14:59:38
mochitest 63547/5/1500

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225411049.1225416001.2392.gzLinux comm-central dep unit test on 2008/10/30 16:57:29
mochitest FAIL
(Reporter)

Comment 7

10 years ago
Crash is gone again between
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225438194.1225444196.5708.gz
Linux comm-central dep unit test on 2008/10/31 00:29:54
and
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1225443838.1225448864.16545.gz
Linux comm-central dep unit test on 2008/10/31 02:03:58
(Reporter)

Comment 8

10 years ago
{
[kairo@kairo.at - 2008/11/13 05:39:32]
figured out that there was no windowmanager actually running and started metacity again.
let's see how that influences this and/or the next cycle.
}
The box is back to green :-)

R.Fixed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 458058
Flags: blocking-seamonkey2.0a2?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.