Closed Bug 462326 Opened 11 years ago Closed 11 years ago

Thunderbird with Lightning leaks on Shutdown.

Categories

(Calendar :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: dbo)

Details

(Keywords: memory-leak)

Attachments

(3 files)

Attached file Leak Log
Thunderbird is just about to have leak and bloat boxes on trunk. At the moment these will definitely go orange due to reference count shutdown leaks within Lightning. These do not occur when just Thunderbird is running.

As when we integrate Thunderbird + Lightning on the builds, this will make the tinderboxes go orange, I think we should try and fix these.

These occur with a basic profile (no calendars defined on startup), and without actually opening a calendar tab.

More information on the profile, and how to run the tests can be found here:

https://wiki.mozilla.org/MailNews:Memory_Bloat_and_Leak_Tests

We may need to investigate trace-malloc leaks as well, but seeing as they will be affected by these, then I suggest we clear these off first.

There may be some related bugs, e.g. Bug 426973 - Sunbird leaking on shutdown, but I wanted one specifically for tracking what would block Lightning integrating with TB.

If you need help investigating, let me know.
Flags: tb-integration?
I think Bug 457024 re-added some leaks to prevent the shutdown crash.
(In reply to comment #1)
> I think Bug 457024 re-added some leaks to prevent the shutdown crash.

That was proposed at one time, but the patch that went in didn't add leaks (it would have probably reduced them).
Right, bug 457024 hasn't added leaks.
I'll have a look at my bloat and XPC_SHUTDOWN_HEAP_DUMP logs, too.
This will turn Tinderbox orange; plussing.
Flags: tb-integration? → tb-integration+
Priority: -- → P1
the mozStorage* leaks point to either the storage calendar or the calendar manager. It might be worth removing any storage calendars (and disabling auto-creating the home calendar), to see what changes.
It might be that the problem is that the two keep each other alive, so be careful with blaming one or the other.
Attached file xpc shutdown heap
Attached patch fix - v1Splinter Review
Seems to be caused by cyclic references via wrapped js objects. This patch removes the init-once references from calUtils.js. We could use a shutdown-observer like I added in calUtils.jsm once we clean up calUtils.js into calUtils.jsm.
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Attachment #350313 - Flags: review?(philipp)
Comment on attachment 350313 [details] [diff] [review]
fix - v1

> cal.LOG("XXXXXXX observing: "...
I'll remove that, of course.
Attachment #350313 - Flags: review?(philipp) → review+
Comment on attachment 350313 [details] [diff] [review]
fix - v1

Looks good to me, if you like go ahead and migrate the accessors to calUtils.jsm?
> (From update of attachment 350313 [details] [diff] [review])
> Looks good to me, if you like go ahead and migrate the accessors to
> calUtils.jsm?
I leave that to another bug; I assume it'll be a lot of changes.

Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/27ee6082367d>

-> FIXED, my bloat log doesn't show them any longer.

Mark, could you please verify (in your setup) whether this is OK now?
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Mac OS X → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.