Cannot launch long URLs to Firefox from Adobe PDF file

VERIFIED INVALID

Status

()

VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: tyler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 (CK-IBM) Firefox/2.0.0.16
Build Identifier: Firefox 2.0.0.16

Error is received when clicking on link in a PDF file when the URL is more than 232 characters.  Receive the Adobe error "An error occurred while trying to communicate with the web browser.".  If IE is confired as default browser, works fine with IE.  Sample URL to try is this:  http://www-01.ibm.com/common/ssi/index.wss?buttonpressed=DET002PT004&page=8&user+type=Regular&panelurl=index.wss%3Fbuttonpressed%3DNAV002PT090&paneltext=Announcement+letter+search&DET002PEF002=&DET002PEF003=&DET002PEF001=5724-I21&DET002PEF004=&al_date_group_index=DET002PT016&ALDATEGROUP=DET002PT016&al_date_index=DET005PEF031&DET002PGL002=DET005PEF031&det003pef003=EXTERNAL&coincidence_index=0&submit.x=54&submit.y=12

Reproducible: Always

Steps to Reproduce:
1.  Create link in a PDF file that is longer than 232 characters
2.  Configure Firefox as default browser
3.  Click link to see failure
Actual Results:  
"An error occurred while trying to communicate with the web browser." error received in Acrobat Reader.  If Internet Explorer is browser, do not get this error.

Expected Results:  
Long URLs work if invoked or pasted directly into Firefox.  Should work from PDF links also but don't.

You may need to collaborate with Adobe on this issue, but I'm posting to Firefox since it works with Internet Explorer.
Please put an example link to an example PDF with such a long URL in the URL field of this bug report.

>3.  Click link to see failure
You are missing one step, open the PDF with what, acrobat Reader or inside a browser with the plugin (which is a complete different plugin in IE) ?
If you click the link in for example Acrobat Reader, is there a difference if Firefox is already open or not ?
Severity: major → normal
(Reporter)

Comment 2

10 years ago
Created attachment 345541 [details]
Test PDF file for demonstrating error
I get no error with Acrobat 8.1.2 but the URL is truncated in Firefox trunk.

Comment 4

10 years ago
These are both working fine for me with Adobe 9.0 and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081030 Minefield/3.1b2pre. Also, I am seeing the entire URL as it is in the doc in the URL bar, it is just to long to fit in the, so you have to scroll.
(Reporter)

Comment 5

10 years ago
I'm using Adobe Acrobat Standard 8.1.2 and Firefox 2.0.0.16.  Does anyone not see the error with this config?
(Reporter)

Comment 6

10 years ago
In reporting the error, the PDF was loaded in a separate Acrobat window, not in a browser plugin.  I just loaded the PDF in a Firefox browser plugin, and the link worked (ignore the fact that the URL isn't valid - I'm uploading another test file which has a valid long URL).
(Reporter)

Comment 7

10 years ago
Created attachment 345577 [details]
New test file with a valid long URL - click highlighed yellow text

Open this PDF in a separate Acrobat window/process, not browser plugin.
my comment#3 is wrong and i got hit by http://kb.adobe.com/selfservice/viewContent.do?externalId=kb403122

Correcting the vista bug i get indeed the error message.with todays Firefox nightly but this could be an Adobe Reader bug.
confirming.
Status: UNCONFIRMED → NEW
Component: General → Shell Integration
Ever confirmed: true
QA Contact: general → shell.integration
Created attachment 345591 [details]
screenshot of security warning prior to Firefox launching

Note how the url is truncated prior to Firefox even launching. This warning is provided by Acrobat itself.
(In reply to comment #8)
> my comment#3 is wrong and i got hit by
> http://kb.adobe.com/selfservice/viewContent.do?externalId=kb403122
We set the additional keys when setting as default as mentioned on this page though it is actually a workaround for apps that don't use the OS provided API's to launch URLs. This would be a bug in Acrobat and shouldn't affect us unless they are doing something different than the majority of apps that don't use the proper API's which would still be a bug in Acrobat.

note: just to be clear when opening the link from within Firefox the URL opens correctly. When opening it from outside of Firefox it is truncated.

> Correcting the vista bug i get indeed the error message.with todays Firefox
> nightly but this could be an Adobe Reader bug.
> confirming.
What specifically is meant by "Correcting the vista bug"? What is the error message that is seen.

As shown by attachement #345591 the truncation occurs prior to Acrobat opening the URL. I verified that this dialog is from the acrobat.exe process and that Firefox had not even been launched when this message was displayed.
>What specifically is meant by "Correcting the vista bug"? What is the error
>message that is seen.
The same error message as the reporter saw in comment#0
The vista bug is that Acrobat launched always IE on my system but SM was the default and it did that also with FF2/3 as default browser.

With attachement #345591 i get no error message anymore but I get a truncated URL. I also switched the default browser from Seamonkey to Firefox2 to Firefox3 to Minefiled during my tests with the OS default application panel(SM is my usual default, FF2 is used by the reporter) and maybe something went wrong during all this switching.

I agree that this looks like a Acrobat Reader issue and not our problem.
Terry, can you get the issue with Adobe Reader 9?
Strange, even after setting IE as the default for the system and the user Acrobat still opened Firefox. Acrobat definitely seems to be doing multiple non-standard things. Also, every so often the message in the Acrobat dialog shown in attachment #345591 [details] would show the complete url but trying to launch the url again would show the url truncated.
(Reporter)

Comment 14

10 years ago
I download Adobe Acrobat Reader 9 and the long URL link works fine with Firefox.  So problem fixed in v9.  That is sufficient for me to resolve this.  Thanks everyone for your help.
marking invalid (fixed in Acrobat)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.