Attachments are no longer forwarded inline with forward inline option

RESOLVED DUPLICATE of bug 307023

Status

RESOLVED DUPLICATE of bug 307023
10 years ago
10 years ago

People

(Reporter: drankinatty, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008091700 SUSE/3.0.3-1.1 Firefox/3.0.3
Build Identifier: version 2.0.0.17 (20080922)

Devs,

    I have used tbird for years, always with the option to forward mail "inline" as opposed to "as attachment". (Edit-> Preferences-> Composition-> General tab-> Forward messages: Inline) Suddenly, tbird no longer forwards attachments in this configuration. I have changed no settings, I have only received updates from the openSuSE (11.0) repositories when they come out.

    Over the past week or so, mail recipients have been replying to my forwards saying "where's the attachment?".

    Checking the sent mail folder -- sure enough, no attachments were sent. I have saved the "Source" file of the most recent email where no attachments were forwarded doing my normal CTRL+L. It's 790K and is available at:

http://www.3111skyline.com/download/error/tbird_fwd-inline-doesnt

    The are 11 small Halloween cartoons that are .jpg attachments (fairly humorous too). Nothing is forwarded with the Inline option set. Setting the option to "As Attachment" does correctly forward the images by sending the entire original .eml file as an attachment.

    What broke inline forwarding?  If there is anything else I can send, just let me know and I'll be happy to provide the information promptly. Thanks.

Reproducible: Always

Steps to Reproduce:
1. set preference for forward to "Inline"
2. receive email with inline .jpg images
3. ctrl+l or choose Message-> Forward
Actual Results:  
No images forwarded inline

Expected Results:  
All images forwarded inline as usual

Comment 1

10 years ago
That message triggers bug 307023, which was fixed two days ago. I've tested it on the current trunk version (November 12), and it works fine for me.

> Over the past week or so, mail recipients have been replying to my forwards
> saying "where's the attachment?".

This is a bit weird as the problem existed for years before finally getting fixed and depends on the format of the message you are replying to. Thus, if this happens only with specific messages, maybe the format they are sent was changed during the last week, thus exposing the bug in the current releases.

As a workaround, you can use Reply rather than Forward and replace the address of the original sender with the one of your intended recipients. Or, with the first Thunderbird 3.0 beta release coming up by the end of this month, you can use it instead (with all the issues related to potentially buggy beta versions) with the bug for the message you posted fixed.
(Reporter)

Comment 2

10 years ago
    Yes, I agree it's weird, but it wouldn't be the first time that quirky changes unfixed a previously fixed bug. What is weird is that with some messages, the attachments will forward inline. But with others, the attachments are not forwarded with the preference set to forward attachments inline.

    The example listed in my first post is one of those. I'll forward it directly to you with the preference set to "inline" and then again with it set "as attachment" and maybe you can make more sense out of it than I can (not hard to do)

    You should have both now. Let me know what else I can do to help.

Comment 3

10 years ago
David, I received your e-mails, thanks. While "as attachment" came up as
expected (the original message just attached unchanged), the "inline" version
was sent in plain-text mode only. Can you resend this in HTML format?

Make sure that HTML composition is enabled in the Edit > Account Settings, Composition & Addressing tab, and that View > Message Body As > Original HTML
is selected when forwarding. You can enforce sending as HTML when selecting
Options > Format > Rich Text (HTML) Only in the composition window.

Comment 4

10 years ago
Never mind, from the message you've sent me and posted on your web site, it is obvious that this would trigger bug 307023, which has recently been fixed. Thus, if you forwarded it to me inline and in HTML format, the images would likely not be sent with it.

As for this occurring just recently, you may have accidentally switched to plain-text composition (judging from the message you've forwarded inline, see my instructions in comment #3), or the sender of these e-mails may have recently changed e-mail client or provider which prefer quoted-printable encoding, thus triggering the bug.

Unless you have some further information that would indicate a problem independent from bug 307023, this can probably closed as a duplicate.

Comment 5

10 years ago
David C. Rankin wrote by e-mail:
> I Can't change any settings, after the last update, I get XML Parse errors in
> all dialogs. What do I do?

David, please do not send private e-mails but keep everything in the report.
The error you see, especially after updating, is usually met with an extension that's not quite compatible and didn't migrate well. Try starting Thunderbird in Safe Mode (use the -safe-mode command line options), and if it resolves your issue, identify and deinstall the extension causing the problem in normal mode.

If you cannot resolve the XML issue or need further help, the TB Support forum would be the better place - http://forums.mozillazine.org/viewforum.php?f=39

Comment 6

10 years ago
Resolving as duplicate per comment #4 now and based on examples received.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 307023
You need to log in before you can comment on or make changes to this bug.