Closed Bug 462632 Opened 11 years ago Closed 9 months ago

Buttons have wrong alignment on about:sessionrestore in Linux

Categories

(Firefox :: Session Restore, defect, trivial)

x86
Linux
defect
Not set
trivial

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ventnor.bugzilla, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Patch (obsolete) — Splinter Review
To answer bug 459751 comment 9, yes, at least on Linux these buttons need to be right-aligned.

Not just on GNOME, I believe every major DE follows this convention; the buttons for the binary choice are right aligned with the affirmative choice on the right and the negative one on the left. If there is a tertiary action, its button is actually left-aligned.

Because I'm not sure if there are specialities in OSX or other non-GTK UNIX platforms, because I can't test regressions on other platforms, and because alignment is likely something that themers want to easily change, I've done this in CSS.

This was fixed in my original patch but someone regressed it. Bugger :(
Attachment #345838 - Flags: review?(zeniko)
Comment on attachment 345838 [details] [diff] [review]
Patch

> #buttons {
>-  -moz-margin-start: 80px; /* same as #errorLongContent in netError.css */
>+  width: 100%;
>+  -moz-margin-start: 0px;
>+  -moz-box-pack: end;
> }

remove -moz-margin-start
Attached patch Patch 2Splinter Review
Sure.
Attachment #345838 - Attachment is obsolete: true
Attachment #345847 - Flags: review?(zeniko)
Attachment #345838 - Flags: review?(zeniko)
Comment on attachment 345847 [details] [diff] [review]
Patch 2

(In reply to comment #0)
> Not just on GNOME, I believe every major DE follows this convention; the
> buttons for the binary choice are right aligned with the affirmative choice on
> the right and the negative one on the left.

That's for dialogs. What about a single button? If that one'd be right aligned as well but the buttons on our error pages aren't, please get ui-review on this patch before landing.
Attachment #345847 - Flags: review?(zeniko) → review+
The reason I'm doing this for two buttons instead of one button is that one button is much easier to locate and know about its function, so its location doesn't matter as much. This is my experience.

But binary choice dialogs are so common in GNOME (or other DEs) that it can disrupt Flow (am I doing this right? :-) ) if the buttons don't follow all these conventions (since they have to spend a little more time looking and thinking about their choice). I guess I can't explain it since I only spent 6 months studying HCI, but to me as a user it feels more natural to follow the convention in this case; to go to the right side and quickly and instinctively know the affirmative/negative action based on placement alone.

Will ask for ui-r.
Attachment #345847 - Flags: ui-review?(beltzner)
Comment on attachment 345847 [details] [diff] [review]
Patch 2

Alex - thoughts here? Should we do this while we get rid of the "start new session" button?
Attachment #345847 - Flags: ui-review?(beltzner) → ui-review?(faaborg)
Attachment #345847 - Flags: ui-review?(faaborg) → ui-review+
We should fix this for the other platforms as well, even though it was just filed for Linux.
(In reply to comment #6)
> We should fix this for the other platforms as well, even though it was just
> filed for Linux.

Is there any platform where we shouldn't right-align?
Windows, Linux and OS X all use a bottom right alignment for dialog buttons.
Michael - Can you update your patch to fix all 3 themes? I'll give it a quick review & we'll see about getting this in at the same time as bug 477322.
Severity: normal → trivial

about:sessionrestore has changed in the last 9 years and doesn't exhibit any misalignment.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.