Closed Bug 462661 Opened 12 years ago Closed 11 years ago

Simplify tag selection for tag auto-completion in tags field

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Firefox 3.5

People

(Reporter: whimboo, Unassigned)

References

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081101 Minefield/3.1b2pre ID:20081101020236

Entering some letters of a tag within the tags field you will see a list of matching tags. Selecting the first matched tag is a bit cumbersome. If you press the enter key the tag is completed but the automatically added letters are highlighted. Means you have to press the right arrow key and enter the colon manually.

I would propose that the tag will be autocompleted and a colon inserted afterwards automatically. That will enhance the user experience a lot. Currently it's not an ideally behavior. Alex, what do you think?
No longer blocks: 415960
Blocks: 415960
It should be OK to add and leave a trailing comma+<space> as long as the last comma is ignored when the user presses <Done>.
Dietrich, could you please give a comment how we can go on with this issue? I've switched to beta2 now and it is really bothersome. I'm reordering and tagging my whole bookmarks now and always have to click right after selecting an entry from the auto complete box doesn't make it easy.

The tags auto complete should really have the same look&feel as all the other auto complete boxes.
Flags: wanted-firefox3.1?
Duplicate of this bug: 474987
Flags: wanted-firefox3.5? → wanted-firefox3.6?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090725 Minefield/3.6a1pre

I think this bug has been fixed (please close it if you agree).
But behaviour is not very good, still. I'd expect that pressing Enter when autocomplete suggests highlighted letters should NOT close the dialogue, but just do autocomplete first.

Selecting the first autocomplete entry using tab or cursor down, then pressing Enter (my reading of steps of comment 0) will complete the word and place cursor behind it (as requested), but without adding anything like komma or space. Against comment #0 and comment #1 I am not sure if adding comma and space automatically would be a good idea, as user will have to remember each time whether to add comma manually (for new tags) or not (for existing tags). It's easier for your muscles to remember that you'll have to add a comma after each tag no matter what.
The bug I referred to in comment #4 is Bug 494530 (pressing Enter in tags autocomplete (not popup) closes bookmarks dialogs).

So I think this bug should be closed worksforme or fixed.
Also fixed in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Lets mark it WFM.
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: wanted-firefox3.6?
Keywords: uiwanted
Resolution: --- → WORKSFORME
Target Milestone: --- → Firefox 3.5
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.