Dependency bug list not updated with reload when it has been changed by another bug

VERIFIED DUPLICATE of bug 452994

Status

()

Bugzilla
Creating/Changing Bugs
--
major
VERIFIED DUPLICATE of bug 452994
9 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Details

This bug is really annoying and has hitten a lot of us during the last weeks. I haven't tested yet if it's a regression by the update to Bugzilla 3.2.

Steps to reproduce:
1. Open a reported bug
2. Open another bug in a new tab, add bug (from step 1) as depend or block bug list, and submit the change
3. Go back to bug (1) and hit reload => dependency bug lists are not updated
4. Add a new comment and submit change

After step 4 the commit from step 2 is reverted and the bug is removed from the list. There is no mid-air collision which alerts the commenter.

Probably the lists have to better be updated with step 3 so the current state is shown. Means no mid-air collision message is needed at all. With the current behavior people will be spammed twice. :/

Comment 1

9 years ago
The behavior you are explaining is completely normal web browser behavior. The form values are saved. Of course there's no mid-air, because you reloaded. You should force-reload if you want the form values updated.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452994
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.