Cannot accept certificates permanently in Thunderbird

RESOLVED DUPLICATE of bug 387480

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 387480
9 years ago
9 years ago

People

(Reporter: jberkus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: version 2.0.0.17 (20080914)

I have a mailserver where the certificate for TLS on the mailserver is signed by a different domain.  Thunderbird gives me the "Certificate does not match" warning *every single time* I log in, and can't be told to "accept certificate permanently".

Reproducible: Always

Steps to Reproduce:
1. Set up a server with a self-signed certificate signed for one domain (e.g. www.whatever.com)
2. Set up a mail server in a vhost on that server, with a different domain (e.g. mail.somethingelse.com).
3. Connect to that mail server through Thunderbird.
4. You will get a "certificate does not match" warning.
Actual Results:  
The only options are "Continue", "Cancel", and "View Certificate".

Expected Results:  
The "Certificate does not match" dialog should have an "accept certificate permanently" option.

I checked under Certificate Management, and the certificate in question is marked "trusted" already.  So I shouldn't be seeing the warning.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 387480
You need to log in before you can comment on or make changes to this bug.