Text shifts when right-click is used

RESOLVED WORKSFORME

Status

()

Core
Layout: Block and Inline
P2
normal
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: David Craig, Unassigned)

Tracking

({fixed1.9.1, regression})

Trunk
x86
Windows XP
fixed1.9.1, regression
Points:
---
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081101 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081101 Minefield/3.1b2pre

Blog post "Presidential Prognostications" on this page 
http://freakonomics.blogs.nytimes.com/

Will have text shift when links are right-clicked. The correct menu then also does not come up for the link. 

Reproducible: Always

Steps to Reproduce:
1. Right click on "analyzing horse-race betting markets."
2. 
3. 
Actual Results:  
The text shifts and the wrong right click menu comes up.


This does not happen with Firefox 3.0
(Reporter)

Comment 1

9 years ago
Created attachment 345909 [details]
Test case, right click "analyzing horse-race betting markets"

Test case, right click "analyzing horse-race betting markets"
This regressed on 12 aug 2008: http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-08-12+00%3A00%3A00&enddate=2008-08-13+00%3A00%3A00
Maybe caused by Bug 230555, Bug 413048 or Bug 406299.
Component: General → Layout: Block and Inline
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout.block-and-inline
Version: unspecified → Trunk
Flags: blocking1.9.1?
Attachment #345909 - Attachment mime type: application/octet-stream → application/zip
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P2
Keywords: qawanted
Can you still reproduce using the testcase?  I tried on Windows and Linux and I couldn't, though I also tried a build from just before it was filed on Linux and couldn't there either.  I could imagine font differences could easily change whether something like this showed up.
(Reporter)

Comment 4

9 years ago
Just reproduced on minefield 20081124 on Windows XP. 

The fonts I could find in the CSS were Arial, generic 'sans serif' and Georgia. I have all three installed.
Could you attach a screenshot of how the text looks both before and after it moves, so that we can see how the text is wrapping in that font and thus see if we're seeing the same fonts?
(Reporter)

Comment 6

9 years ago
Created attachment 351114 [details]
image of text, to determine font.
(Reporter)

Comment 7

9 years ago
The issue appears to have been resolved, yesterday and today's build don't have an issue. 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081202 Shiretoko/3.1b3pre

Attached screen-shot anyways...
OK, marking as worksforme, then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Adding a fixed1.9.1 keyword for lack of a worksforme1.9.1 keyword.
Keywords: fixed1.9.1

Comment 10

9 years ago
working just fine for me, windows xp

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090129 Shiretoko/3.1b3pre
Issue is Resolved - removing QA-Wanted Keywords - QA-Wanted query clean-up task
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.