Building fails with -j19 option enabled

VERIFIED FIXED

Status

VERIFIED FIXED
10 years ago
7 months ago

People

(Reporter: romaxa, Assigned: benjamin)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
Created attachment 345928 [details]
Full build log

Mozconfig:
ac_add_options --enable-application=xulrunner
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj-dir
mk_add_options MOZ_MAKE_FLAGS=-j19
ac_add_options --disable-javaxpcom

Fill build log in attachments
..............
No rule to make target `export'.  Stop.
make[6]: nsIWyciwygChannel.idl
*** [resources_export] Error 2
make[6]: *** Waiting for unfinished jobs....
creating content/xml/document/resources/Makefile
..............
creating content/xbl/test/Makefile
Creating .deps
make[5]: *** [document_export] Error 2
make[4]: *** [xml_export] Error 2
make[4]: *** Waiting for unfinished jobs....
nsIXMLContentBuilder.idl
creating content/mathml/content/src/Makefile
creating content/media/video/test/Makefile
..............
nsISelection.idl
Creating .deps
make[3]: *** [export_tier_gecko] Error 2
make[2]: *** [tier_gecko] Error 2
make[1]: *** [default] Error 2
make: *** [build] Error 2
Hm, it looks like your build started |make export| before it finished generating Makefiles. I guess we need an explicit dependency there somewhere.
(Assignee)

Comment 2

10 years ago
Yeah, add %/Makefile as a dependency of the directory recursion rules.
(Assignee)

Updated

10 years ago
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Created attachment 346043 [details] [diff] [review]
add the right dependency on %/Makefile

romaxa: give this patch a try?

I had a dependency on the Makefiles, but it was not in the right place in the dependency graph, so the Makefiles could get generated in parallel with actually calling export on the dirs. Oops...
Assignee: benjamin → ted.mielczarek
Attachment #346043 - Flags: review?(benjamin)
Sunbird tinderbox triggers the same error (Bug 462839), at least I assume so.
Duplicate of this bug: 462839
(Assignee)

Comment 6

10 years ago
Created attachment 346055 [details] [diff] [review]
add the dependency on %/Makefile and fix the $*/% mess by switching to a single-colon rule
Assignee: ted.mielczarek → benjamin
Attachment #346043 - Attachment is obsolete: true
Attachment #346055 - Flags: review?(ted.mielczarek)
Attachment #346043 - Flags: review?(benjamin)
Attachment #346055 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 7

10 years ago
Created attachment 346057 [details] [diff] [review]
add the dependency on %/Makefile and fix the $*/% mess by switching to a single-colon rule, rev. 2

add phoniness
Attachment #346055 - Attachment is obsolete: true
Attachment #346057 - Flags: review?(ted.mielczarek)
Attachment #346057 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 8

10 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/d38b03a1651b
and copied to js/src :-( http://hg.mozilla.org/mozilla-central/rev/c56b266cdb75
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

10 years ago
Works fine now.
Status: RESOLVED → VERIFIED

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.