new filter isn't selected after create new filter - then newly created filter is not selected. Run now runs something else.

RESOLVED DUPLICATE of bug 620391

Status

MailNews Core
Filters
--
minor
RESOLVED DUPLICATE of bug 620391
10 years ago
7 years ago

People

(Reporter: thud, Unassigned)

Tracking

1.9.1 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008102102 Gentoo Firefox/3.0.3
Build Identifier: version 2.0.0.17 (20081017)

having created a new filter it is most likely that I will want / need to run it to check whether it has been correctly set up. The run now button would seem to do that but in the case of a new filter it runs something else (the filter selected prior to adding a new one).


Reproducible: Always

Steps to Reproduce:
1. add a new filter
2. hit "run now"
3. new filter does not have the highlight and does not get run
4. the last filter selected before created new one does get run.
So if you enable the filter log - what does the log says is being run ?

Any error messages when this happens ?
Component: General → Filters
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Whiteboard: [closeme 2009-11-26]
Version: unspecified → 1.8 Branch

Comment 2

9 years ago
are you saying the new filter should be highlit when created and you are seeing different behaviour than I reported?
(In reply to comment #2)
> are you saying the new filter should be highlit when created and you are seeing
> different behaviour than I reported?

I'm asking a few questions - I don't run you version of Thunderbird (I run a more recent version - so I can't really see your issue.). I want to gather more information for two reasons :

1) figure out if this has been fixed already - 
2) figure out what's broken so we can fix it.

Comment 4

9 years ago
OK, I have realised that you are misinterpreting what I reported. 

It is not that I select the new filter and it runs something else. The problem is that the new filter is not selected automatically. Hence hitting "Run now" runs the previously selected filter. This is counter intuitive and probably not what one would expect or need to do have just created a new filter.

I would suggest that having created a new filter it should become the currently selected filter automatically so that Run now applies the new filter (not the arbitrary filter that happened to be selected at the moment I decided I needed to define a new one).

It's an interface defect rather than a programming bug.

Sorry if my attempts to conform to Step 1, step2, step3 made this less clear.

Suggest: on successfully adding a new filter it becomes the actively selected filter such that "Run now" runs the new filter.


Thx
Severity: minor → normal
Component: Filters → Mail Window Front End
OS: Linux → All
Product: MailNews Core → Thunderbird
QA Contact: filters → front-end
Hardware: x86 → All
Whiteboard: [closeme 2009-11-26]
Version: 1.8 Branch → Trunk
confirming on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.6pre) Gecko/20091107 Shredder/3.0pre
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Severity: normal → minor
Summary: newly created filter is not selected. Run now runs something else. → new filter isn't selected after create new filter - then newly created filter is not selected. Run now runs something else.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Component: Mail Window Front End → Filters
Product: Thunderbird → MailNews Core
QA Contact: front-end → filters
Resolution: --- → DUPLICATE
Version: Trunk → 1.9.1 Branch
Duplicate of bug: 620391
You need to log in before you can comment on or make changes to this bug.