"Recently closed tabs" should include recently closed windows; or undo option for closed windows.

RESOLVED DUPLICATE of bug 394759

Status

()

--
major
RESOLVED DUPLICATE of bug 394759
10 years ago
10 years ago

People

(Reporter: theosib, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3

If I accidentally close a tab, I can find it again by going to History >> Recently Closed Tabs.  Very nice.  However, if I accidentally close a window (which usually only happens when it has a single tab), I find that "Recently Closed Tabs" is grayed out.  So not only can I not restore the window, but I wouldn't be able to restore any tabs closed earlier.  Note that usually, when I accidentally close a window, I don't actually know what I closed (because it was accidental), which is really frustrating, because then I have no idea what I lost.  If a user gets frustrated and confused, that's usually a sign of a UI that could be improved.  Moreover, all destructive actions should have some sort of undo; the Undo option does not apply to windows, which seems like a major oversight.

I suggest either adding recently closed windows to the "recently closed tabs" menu (particularly if that window had only one tab), or adding a "recently closed windows" option.


Reproducible: Always

Steps to Reproduce:
1.  
2.  
3.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394759
You need to log in before you can comment on or make changes to this bug.