[FLOAT] float should not be higher than cleared float on same side

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
major
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Jeremy Wrinkle, Assigned: buster)

Tracking

(Blocks: 1 bug, 4 keywords)

Trunk
Future
x86
Windows 98
css1, helpwanted, relnote, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P2] (high profile: css1 test suite) relnote-devel)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2000072108

 Hello,

This page that I am attaching to this bug looks terrible in Mozilla. For the 
correct way to display it, look at it in MSIE 5.5. And, when you take out the 
commented code, Mozilla crashes.

Reproducible: Always
Steps to Reproduce:
1. Open page in Mozilla.

Actual Results:   The page is rendered with tables overlapping.			
				

Expected Results:   The page should render like it does in MSIE 5.5
(Reporter)

Comment 1

18 years ago
Created attachment 11824 [details]
Page that looks bad in Mozilla.
Created attachment 11828 [details]
Minimised test case
This shows a violation of section 9.5.1.2 of the CSS2 float layout rules, which
reads as follows:

# 2. If the current box is left-floating, and there are any left floating
#    boxes generated by elements earlier in the source document, then for
#    each such earlier box, either the left outer edge of the current box
#    must be to the right of the right outer edge of the earlier box, or its
#    top must be lower than the bottom of the earlier box. Analogous rules
#    hold for right-floating boxes.
Assignee: clayton → buster
Keywords: correctness, css1, nsbeta3, testcase
QA Contact: petersen → chrisd
Summary: Mozilla renders valid HTML and CSS horribly. → float should not be higher than cleared float on same side
Summary: float should not be higher than cleared float on same side → [FLOAT]float should not be higher than cleared float on same side

Comment 4

18 years ago
For starters, that page has an embedded html comment - which is a nono.
Jelwell: It does, yes, but that has nothing to do with the visible error. You
will notice that the minimised testcase has no comment in it.

Comment 6

18 years ago
Denying approval for beta3: too many bugs and not enough resources, so this one 
will have to be atteneded to in the future.
Whiteboard: [nsbeta3-]
We still fail this, which EVEN INTERNET EXPLORER 5 GETS CORRECT. By not 
fixing this we are making the 'float' property unreliable for web authors, 
since we would be displaying it incorrectly while the competition would be 
doing it right.

This is almost certainly related to bug 4831, which is a similar bug for floats
on opposite sides.
Keywords: 4xp, relnote
QA Contact: chrisd → py8ieh=bugzilla
Summary: [FLOAT]float should not be higher than cleared float on same side → [FLOAT] float should not be higher than cleared float on same side
I know we still do not have enough resources to get this fixed. However:

Removing [nsbeta3-] to put this floater bug (and 3 others) back onto the 
developer radar, as per suggestion by Gerardo.
Keywords: helpwanted
Whiteboard: [nsbeta3-] → (beta3 minus per triaging)
(Assignee)

Comment 9

18 years ago
changed (beta3 minus per triaging) to [nsbeta3-] so searches work correctly
Status: NEW → ASSIGNED
Whiteboard: (beta3 minus per triaging) → [nsbeta3-]
(Assignee)

Comment 10

18 years ago
changed (beta3 minus per triaging) to [nsbeta3-] so searches work correctly
Whiteboard: [nsbeta3-] → nsbeta3-]
(Assignee)

Comment 11

18 years ago
changed (beta3 minus per triaging) to [nsbeta3-] so searches work correctly
Whiteboard: nsbeta3-] → [nsbeta3-]
(Assignee)

Comment 12

18 years ago
all P3 bugs are Future, will not make RTM of NS6.
Target Milestone: --- → Future
Whiteboard: [nsbeta3-] → [nsbeta3-] relnote-devel

Comment 13

18 years ago
The Minimised test case looks the same in NS6 as it does in IE5.5 - and no divs
are overlapping - was this bug fixed?
(Reporter)

Comment 14

18 years ago
 No, this bug still exists but it no longer crashes Mozilla. Here is the
original page:

http://www.w3.org/Style/CSS/Test/w3c.html

The page looks like **** in Mozilla (thought still readable) but it is rendered
right in MSIE 5.5
To be more accurate, (if I remember correctly -- I didn't check just now) that
W3C demo page was written assuming a bug that IE has.

However, Ian's "Minimised test case" above still clearly shows the bug.
Keywords: nsbeta3 → mozilla0.9, nsbeta1
Whiteboard: [nsbeta3-] relnote-devel → [Hixie-P2] (high profile: css1 test suite) relnote-devel

Comment 16

18 years ago
I have a page that with mozilla 0.7 rendered well and now with 0.8 crashes when
I click on floated links. the page is
http://www.renudo.it/renudo/abbonamenti/welcome.html
Blocks: 78094
Giovanni: please file a new bug if you haven't already -- thanks.

This is fixed now, no? I think Waterson fixed it. I can't see a bug in   
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=11828...any more.
Marking WORKSFORME. David, could you verify? Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.