xforms submit failed when se replace instance to another

RESOLVED WONTFIX

Status

Core Graveyard
XForms
--
major
RESOLVED WONTFIX
10 years ago
2 years ago

People

(Reporter: aredian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 0.8.66ff

<?xml version="1.0"  encoding="utf-8"?>

<html xmlns="http://www.w3.org/1999/xhtml"
      xmlns:xf="http://www.w3.org/2002/xforms"
      xmlns:ev="http://www.w3.org/2001/xml-events"
      xmlns:xsd="http://www.w3.org/2001/XMLSchema"
      xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
      xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:ser="http://service.hcd.hactl.com"
      xmlns:ns1="http://service.hcd.hactl.com"
      >
<head>
  <xf:model id="my-model"  xmlns="">
      <xf:instance id="testado">
         <xf:data xmlns="">
        <XBody><address>testado</address></XBody>
        </xf:data >
     </xf:instance>
     


  <!--<xf:instance id="submit-instance" >
     	<soapenv:Envelope   xmlns:xsd="http://www.w3.org/2001/XMLSchema"
                                            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                                             xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
                                             >
                       <soapenv:Header/>

                         <soapenv:Body>
                         <ser:getAwbInfo soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
                             <awbNumber xsi:type="xsd:string">160-3888898</awbNumber>
                        </ser:getAwbInfo>
         </soapenv:Body>
                     </soapenv:Envelope>
     </xf:instance> -->

  <xf:instance id="submit-instance" >
      <soapenv:Envelope  xmlns:xsd="http://www.w3.org/2001/XMLSchema"
                                            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                                             xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
         <soapenv:Header/>
         <soapenv:Body>
             <ser:checkAwb soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
               <swbNumber xsi:type="xsd:string">test</swbNumber>
             </ser:checkAwb>
         </soapenv:Body>
     </soapenv:Envelope>
     </xf:instance>
     


     <xf:instance id="response-instance">
      <soapenv:Envelope  xmlns:xsd="http://www.w3.org/2001/XMLSchema"
                                            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                                             xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
        <soapenv:Body>
          <ns1:checkAwbResponse soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" >
            <checkAwbReturn xsi:type="xsd:string">12</checkAwbReturn>
          </ns1:checkAwbResponse>
        </soapenv:Body>
      </soapenv:Envelope>
     </xf:instance>


     <xf:submission id="callWebService"  method="post"
          action="http://gsl085:8080/axis/services/PpkServer"
          ref="instance('submit-instance')" replace="instance" instance="response-instance">
                 <xf:header>
                     <xf:name>SOAPAction</xf:name>
                     <xf:value>http://gsl085:8080/axis/services/PpkServer</xf:value>
                    </xf:header>
                    <xf:header>
                     <xf:name>Content-Type</xf:name>
                     <xf:value>text/xml;charset=utf-8</xf:value>
                    </xf:header>
                       <xf:message ev:event="xforms-submit"
                         level="modal">callWebService  Submitting...</xf:message>
                        <xf:message ev:event="xforms-submit-done"
                          level="modal">callWebService Submission complete</xf:message>
                         <xf:message ev:event="xforms-submit-error"
                           level="modal">callWebService Can't submit!</xf:message>

       </xf:submission>
          
     <xf:submission id="putsavelocalfile"
           action="file:///C:/auctionDoc.xml"
            ref="instance('submit-instance')"
                        replace="none" method="put"

          >
           <xf:message ev:event="xforms-submit"
                         level="modal">Put Submitting...</xf:message>
                        <xf:message ev:event="xforms-submit-done"
                          level="modal">Put Submission complete</xf:message>
                         <xf:message ev:event="xforms-submit-error"
                           level="modal">Put Can't submit!</xf:message>

     </xf:submission>
     

  </xf:model>

</head>
<body>


   test    : soap  message input

   
    <xf:input ref="instance('submit-instance')/soapenv:Body/ser:checkAwb/swbNumber">
   <xf:label>AWB:</xf:label></xf:input>

  <p/>
   


    <xf:submit submission="callWebService">
		<xf:label>Submit SOAP</xf:label>
	</xf:submit>

    

  <p/> check awb result
    <xf:input ref="instance('response-instance')/soapenv:Body/ns1:checkAwbResponse/checkAwbReturn">
            <xf:label>awb validate: </xf:label>
        </xf:input>

</body>
</html>
--
I saved it named awb.xhtml on local file . then click subit soap button.it failed.

Reproducible: Always

Steps to Reproduce:
1.click "soap submit"
2.it display 'callWebService Can't submit!"
3.
Actual Results:  
always

Expected Results:  
1)the awb.xhtml saved it local disk,   submit to server. however, no any request to tomcat server. And then rememove "replace="instance" instance="response-instance", it submit request to server.
2)It the awb.xhtml file is savedin tomcat web folder and  use http:// to  access, it's ok

Comment 1

10 years ago
I guess it's dupe of bug 457169
Summary: xforms submit falied when se replace instance to another → xforms submit failed when se replace instance to another

Comment 2

10 years ago
Reed, you removed everyone off the CC list.  Was that intentional?
(In reply to comment #2)
> Reed, you removed everyone off the CC list.  Was that intentional?

Indeed, it was, as clark.rao@gssd.com.cn added over a hundred people to the CC list for no apparent reason, so I was cleaning up his mess.
RIP xforms
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.