Closed Bug 462990 Opened 11 years ago Closed 11 years ago

Outlook 2003 Calendar UID are line wrapped when added to Calendar -

Categories

(Calendar :: Internal Components, enhancement)

Lightning 0.9
enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kylea, Assigned: dbo)

Details

(Whiteboard: [libical-upstream?])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: LIghtning 0.9

Outlook 2003 Calendar UIDs are line wrapped when added to Calendar eg:

DTSTAMP:20081104T051232Z

UID:

 040000008200E00074C5B7101A82E00800000000003B28172CFDC801000000000000000010

 000000A6DBD1BF2CB17A4CBBCDDD613E2A17B5

SUMMARY:Updated: DC Project - 2nd SOP Review Workshop (Day 1).


When these events are sent to my Nokia Mobil phone via Bluetooth Multisync - the process hangs and does not complete.

This is repeatable, If I edit the Calendar.ics file and remove the line wraps its all good. If I open the event via Lightning and re-save the UID is wrapped as above and any update attempt via Multisync will hang. This also has the side effect of duplicating any existing events.

Reproducible: Always

Steps to Reproduce:
1. Outlook 2003 Calendar event _ Accept in Thunderbird/Lightning
2. UID is wrapped onto next line
3. Run MultiSync to update mobile Phone via Bluetooth
Actual Results:  
Multisync hangs and fails to complete its update of the phone. Duplicating and existing calendar events on the phone.


This is a major pain for me as everyone else in my work place uses Windows. I am the lone warrior trying to break down the barriers.
Version: unspecified → Lightning 0.9
The UID needs to look like this for the update via Multisync to work successfully. 

UID:040000008200E00074C5B7101A82E00800000000003B28172CFDC801000000000000000010000000A6DBD1BF2CB17A4CBBCDDD613E2A17B5
I doubt there are any exceptions, but rfc2445 specifies that lines should be wrapped at 80 (?) characters, and line continuations having one space at the beginning of the next line and then the rest of the line (until 80 chars of course).

This looks more like a multisync bug, or an issue with your phone?
Its not the phone - tried 2 x 6233 and 6110.

Its the break at the UID label that causes the problem. You may also be right that Multisync should handle it, but it does not seem to. 

UID:  <------- this is how it appears in the file
 040000008200E00074C5B7101A82E00800000000003B28172CFDC801000000000000000010
 000000A6DBD1BF2CB17A4CBBCDDD613E2A17B5
This will work if I edit the Calendar.ics file

UID:040000008200E00074C5B7101A82E00800000000003B28172CFDC801000000000000000010
 000000A6DBD1BF2CB17A4CBBCDDD613E2A17B5
So you receive an invitation via email. Does the attachment from outlook already have this behavior, that the line is wrapped directly after UID: ? Or does this happen only when exporting from Lightning?
This is the data from the Outlook .ics file

SUMMARY:Updated: DC Project - 2nd SOP Review Workshop (Day 1).
UID:040000008200E00074C5B7101A82E00800000000003B28172CFDC801000000000000000
 010000000A6DBD1BF2CB17A4CBBCDDD613E2A17B5

This is the data in the calendar.ics file:

UID:

 040000008200E00074C5B7101A82E00800000000003B28172CFDC801000000000000000010

 000000A6DBD1BF2CB17A4CBBCDDD613E2A17B5

SUMMARY:Updated: DC Project - 2nd SOP Review Workshop (Day 1).
Please note the is not lines between on the second UID string. The web site is adding those:

UID:
 040000008200E00074C5B7101A82E00800000000003B28172CFDC801000000000000000010
 000000A6DBD1BF2CB17A4CBBCDDD613E2A17B5
Attached patch patch - v1 β€” β€” Splinter Review
libical starts folding if the first line (of a multi-line property) has a ' ', ';' or ':' which is not wrong due to <http://tools.ietf.org/rfcmarkup?doc=draft-ietf-calsify-rfc2445bis-07#section-3.1>, but IMHO unnecessary.

Kyle, you should file a bug against Multisync, too.
Assignee: nobody → daniel.boelzle
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #346682 - Flags: review?(philipp)
Assignee: daniel.boelzle → nobody
Severity: normal → enhancement
Component: Lightning Only → Internal Components
OS: Linux → All
QA Contact: lightning → base
Hardware: PC → All
Assignee: nobody → daniel.boelzle
Ok I'll file a bug with Multisync.

Kylea
Attachment #346682 - Flags: review?(philipp) → review+
Looks good, we should make sure the libical part gets pushed upstream.

Please remind me to contact dothebart about either pushing or giving me svn access.


r=philipp
philipp, let me know your sf.net handle, so I can add you.
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/3c377a3fb7de>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Attached patch current libical changes β€” β€” Splinter Review
Wilfried/Philipp, these are our current changes to libical 0.40. It's a slightly modified diff against rev 714 of comm-central. Would be cool to see some of this upstream libical, which makes updating easier for us in the future. Thanks!
Whiteboard: [libical-upstream?]
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.