Error message on startup: IsThreadDesktopComposited could not be located

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Simon Porter, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081104 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081104 Minefield/3.1b2pre

When I start the nightly build of Minefield I get this error message. I am not sure the regression range, I believe it to be at least 6 weeks.

"The procedure entry point IsThreadDesktopComposited could not be located in the dynamic link library USER32.dll. "

Windows XP SP3
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081104 Minefield/3.1b2pre ID:20081104040308

I get a similar message in a few other apps, Winamp was one but they have since fixed this in the latest release.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield
2. The error will display, click OK
3. Minefield starts and operates normally
Actual Results:  
This error displays:
---------------------------
firefox.exe - Entry Point Not Found
---------------------------
The procedure entry point IsThreadDesktopComposited could not be located in the dynamic link library USER32.dll. 
---------------------------
OK   
---------------------------

Expected Results:  
The error should not display
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Google gives 51 results, could you try some of them?
(Reporter)

Comment 2

10 years ago
It seems to have something to do with dwmapi.dll
I had this issue with Winamp on a machine running WinXp SP2 and IE 8 installed as well as on a machine with WinXp Sp3 and IE7 installed. Winamp seems to have fixed whatever the issue was though.
This does no happen in FireFox 3 startup.

My user32.dll is version 5.1.2600.5512

I have a dwmapi.dll in c:\windows of version 6.0.5384.4, seems an odd location for it, not sure what put it there.

I renamed the file and the issue is resolved:
http://groups.google.fr/group/microsoft.public.windowsxp.general/browse_thread/thread/ffe00f0300aa94f5

Not sure if this should be resolved fixed if the other users are going to see the same issue with the 3.1 release.

Comment 3

9 years ago
Hi.

I just found this report because this "Bug" also appears on my Machine starting Firefox...

My Version: 3.5 RC2
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729) Creative ZENcast v2.00.14

In my case I found the file at C:\WINDOWS\system32\dwmapi.dll (also Version 6.0.5384.4). I'm running WinXP Home SP3 with IE8 installed.

Is this the right place for this Bug or should it be entered as new?
(In reply to comment #3)

Appears to be the same problem.
Duplicate of this bug: 512071
Duplicate of this bug: 514880
Duplicate of this bug: 542042
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
This bug has had the CLOSEME tag for several weeks and the date in the tag is
far gone. If the reporter can still see this issue, Please retest with Firefox
3.6.x or later and a new profile
(http://support.mozilla.com/kb/Managing+profiles). Then please remove the
closeme tag in the whiteboard, mark the bug against the proper version and
comment on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.