Check box of about:sessionrestore is invisible with High-Contrast theme of Windows.

RESOLVED FIXED in Firefox 3.6a1

Status

()

Firefox
Session Restore
P2
minor
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Masahiro YAMADA, Assigned: faaborg)

Tracking

({access, fixed1.9.1})

3.5 Branch
Firefox 3.6a1
x86
Windows XP
access, fixed1.9.1
Points:
---
Bug Flags:
blocking-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [icon-3.1][icon-complete])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.1b2pre) Gecko/20081104 Minefield/3.1b2pre

Now, check box always uses single image that contains only black and transparent.
When setting desktop design of Windows sets Highlight Color as Black, checkbox is invisible.

Reproducible: Always

Steps to Reproduce:
1.Change Your desktop theme as High Contrast #1
2.Show some webpage with firefox.exe
3.Stop firefox.exe from Task Manager.
4.Run firefox.exe again

Actual Results:  
Checkbox is not visible

Expected Results:  
Checkbox should be visible.
(Reporter)

Updated

9 years ago
Keywords: access

Comment 1

9 years ago
Alex: Please keep this in mind when asking for new graphics. AFAIK in other places we had a whitish outline around black shapes (e.g. for the dropdown markers).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Summary: Check box of about:sessionrestore is invisible with Hign-Contrast theme of Widows. → Check box of about:sessionrestore is invisible with High-Contrast theme of Widows.
(Reporter)

Updated

9 years ago
Summary: Check box of about:sessionrestore is invisible with High-Contrast theme of Widows. → Check box of about:sessionrestore is invisible with High-Contrast theme of Windows.
(Assignee)

Comment 2

9 years ago
Yeah, we are usually pretty good at not messing this up.  That checkbox image has been around for a really long time, but the problem never came up because this is the first time we are using it in Firefox (as far as I know).  I'll get this fixed.
Assignee: nobody → faaborg
Whiteboard: [icon-3.1]

Updated

9 years ago
Depends on: 471320
(Assignee)

Updated

9 years ago
Whiteboard: [icon-3.1] → [icon-3.1][icon-refresh]
(Assignee)

Comment 3

9 years ago
Created attachment 372814 [details]
Replacement cbox-check.gif

this file needs to replace the file currently at:

/source/toolkit/themes/winstripe/global/checkbox/cbox-check.gif
(Assignee)

Comment 4

9 years ago
Requesting blocking due to accessibility issue with session restore, and the fix is just dropping in the attached new icon.
Flags: blocking-firefox3.5?
Whiteboard: [icon-3.1][icon-refresh] → [icon-3.1][icon-complete]
Flags: blocking-firefox3.5? → blocking-firefox3.5+
Priority: -- → P2

Updated

9 years ago
Attachment #372984 - Flags: review?(dao) → review+
Comment on attachment 372984 [details] [diff] [review]
new icon

cbox-check-dis.gif also uses only one shade of gray, but that seems less critical.

Updated

9 years ago
Keywords: helpwanted
(Assignee)

Comment 7

9 years ago
>cbox-check-dis.gif also uses only one shade of gray, but that seems less
>critical.

as far as I know we aren't currently using that image in Firefox, and the one shade of grey it uses should appear ok on a black background.  Either way this get's solved by the broader bug 462618 to use native check boxes.
It's used in about:sessionrestore next to "Window X" when some tabs are unchecked. I suppose it would be invisible or nearly invisible with some of the Classic flavors, but I haven't tested it.
http://hg.mozilla.org/mozilla-central/rev/752c18ea8cdb
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/1eb81c6e8aa2
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.6a1
Version: unspecified → 3.1 Branch
You need to log in before you can comment on or make changes to this bug.