Patch the CRT so that Crash Reporter can catch __pure_virtual etc.

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: neil, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Since we're patching the CRT already, would it be possible to catch some __pure_virtual calls by making the CRT trigger a crash rather than exiting?

I realise that this will only catch crashes in the core code, not plugins etc.
Breakpad uses _set_purecall_handler, which appears to work in my testing:
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc#143

Are there pure virtual calls we're not catching? I tested using the code example from the MSDN page:
http://msdn.microsoft.com/en-us/library/t296ys27%28VS.80%29.aspx
(Reporter)

Comment 2

10 years ago
timeless was complaining about it in his blog, so I thought it was a problem.
(Reporter)

Comment 3

10 years ago
Actually all those CRT dialogs look alike, it might have been a different one.
Do we actually fail to catch this in Mozilla?
timeless says he wasn't explicitly complaining about this in Mozilla, although we can still hit this in third-party libraries, since we don't let them link to our CRT, and the purecall handler is per-CRT.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.