Closed Bug 463203 Opened 11 years ago Closed 11 years ago

Hotmail broken in Ubuntu Firefox builds after site updated (bad user agent sniffing)

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jazzy_clarinet, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

After the Microsoft Hotmail site update today I cannot get the cursor to enter the main message box to type a message.  It is OK on a machine running windows and firefox 3.0.3 but not on my ubuntu machine used to give build identifier above.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
and you tried the safemode before reporting this bug ?
http://support.mozilla.com/en-US/kb/Safe+Mode
I have ran into this as well on both mac and windows with 3.1b1 and today's nightly:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081106 Minefield/3.1b2pre

What happens is I can load up hotmail, but cannot create an email, delete an email, and have trouble browsing folders.  I looked at the page source, but it isn't very helpful:
<li aid="DeleteMessages" class="ToolbarItem "><a title="Delete" href="javascript:;" id="DeleteMessages">
    <span class="Label">Delete</span></a></li>
I just tried this in safe mode inside of the minefield nightly and it reproduces.
Status: UNCONFIRMED → NEW
Ever confirmed: true
moving this to tech evangelism, seems like a non-standard DOM issue.  I confirm, i can't even view my emails in the preview pane. 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
OS: Linux → All
There's a regression range for this.  See:  Bug 462428

I'll leave it up to you to determine which you want to dupe to which.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462428
This is not bug 462428. That's for Minefield; this is for Firefox 3.0.3 on Ubuntu.

With the Ubuntu build of Firefox 3.0.3 it comes up with a "please upgrade your browser" page, probably because it's not detecting the user agent correctly. After getting in the folders work fine (unlike bug 462428) but you can't type in the message area as in comment 0 here. If I install the official Mozilla build of the same Firefox version on that machine I can then use things fine.

Ubuntu build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

Mozilla build:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3

The problem seems to be that Hotmail chokes on the "Ubuntu/x.yy (name)" bit and can't figure out that it's Firefox. The version of the page it then sends out doesn't work under Firefox 3, whereas the version it sends to the correctly detected browser works fine.

If you're in the Ubuntu build you can install the user agent switcher extension and pretend to be the official build, in which case Hotmail doesn't get confused and things work just fine. It's just Microsoft's user agent sniffing that seems to be broken here.
Status: RESOLVED → REOPENED
OS: All → Linux
Resolution: DUPLICATE → ---
Summary: Hotmail Broken after Site Updated → Hotmail broken in Ubuntu Firefox builds after site updated (bad user agent sniffing)
Status: REOPENED → NEW
The problem here is that two separate bugs occurred due to the recent Hotmail update: one for 3.1 and one for 3.0 on Ubuntu. Comments 2-5 are for the former and the initial report is the later.

Note that you can just take the official user agent and stick in "test" before the Firefox version and that's enough to confuse it. This bug probably applies to any other Firefox builds that add something to their user agent.
Why is this not a dupe of bug 396259? We already have one TE bug on Hotmail's totally busted non-Firefox browser sniffing; we don't need multiples.
Duplicate of this bug: 464595
(In reply to comment #9)
> Why is this not a dupe of bug 396259? We already have one TE bug on Hotmail's
> totally busted non-Firefox browser sniffing; we don't need multiples.

This is a new problem caused by Hotmail's recent upgrade, but its cause is a fairly standard issue. Linux users with a distro build could previously use Hotmail and now they cannot at all, as there doesn't seem to be a "classic mode" anymore. I guess you could either consider this to be a new issue which completely breaks things after the upgrade or the same old same old, but now with a much larger effect.

Most of 396259 is for non-Firefox Gecko browsers and betas, as is the title, though there are a few mentions of distro builds of Firefox in there. This bug is a little different, but If you don't want to have more than one bug tracking the problems with their crappy sniffing then dupe away. (in which case someone should probably file another TE bug about the fact that "classic mode" is gone and the non-browser-specific full version doesn't work)
this issue is on all platforms, not just linux/ubuntu
(In reply to comment #12)
> this issue is on all platforms, not just linux/ubuntu

It's unclear to me whether the old bug is still consistently reproducible; what platform are you seeing the problem on?

We've had several reports on the MZ forum recently that Hotmail is broken for Camino users, but I no longer have a Hotmail account and can't do any testing myself.
(In reply to comment #13)
> I no longer have a Hotmail account and can't do any testing myself.

Have a Hotmail account:
asdgdsdag@hotmail.com
pass: asdfgh

Takes all of 3 seconds to setup one to test with. (which is why so many sites won't accept them when asking for a valid email these days)
At this time of me writing this this isnt a problem with Firefox-3.0.6 in Ubuntu 9.04 or 8.10 however this is a problem for pre release version 3.1 and 3.2, This is an MS issue more so that Firefox since it would be unreasonable to upgrade firefox every time Hotmail updates, they seem to upgrade thier servers atleast 1 time a month.
This bug and bug 400538 are duplicates I am unable to mark duplicates.
(In reply to comment #16)
> This bug and bug 400538 are duplicates I am unable to mark duplicates.

No it's not. Bug 400538 is old and for WinXP and this is for Linux, specifically Ubuntu. See comment 11 above. If anything, this is in part a dupe of bug 396259 which I chose to keep separate because this was about a specific new case of their crappy UA sniffing. The 3.1/3.2 issues mentioned in comment 15 are bug 396259 or bug 462428 if it's an old enough build.

Regardless, this does seem to be fixed on their end now. Just tested using the Ubuntu user agent in comment 7 and it seems to work fine. Closing.
Status: NEW → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.