Closed Bug 463278 Opened 13 years ago Closed 13 years ago

De-extensionify gloda

Categories

(MailNews Core :: Backend, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0b1

People

(Reporter: Nomis101, Assigned: philor)

References

Details

Attachments

(3 files, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_5; de-de) AppleWebKit/528.1 (KHTML, like Gecko) Version/4.0 Safari/528.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081105 Shredder/3.0b1pre

In the newer builds I get the following warning in the error console:

> Warning: Warning: Duplicate resource declaration for 'gloda' ignored.
> Source File: file:///Volumes/Shredder/Shredder.app/Contents/MacOS/chrome/gloda.manifest
> Line: 1

If I than click on the link in this warning I get two new errors:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]

and

Error: [Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIDocShellHistory.useGlobalHistory]"  nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame :: chrome://global/content/bindings/browser.xml ::  :: line 643"  data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 647

Reproducible: Always

Steps to Reproduce:
1. Open Thunderbird and look into the error console
2. Click on the link in the displayed warning
Actual Results:  
First you will see the warning and than this two errors
(In reply to comment #0)
> > Warning: Warning: Duplicate resource declaration for 'gloda' ignored.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081105 SeaMonkey/2.0a2pre] (nightly) (W2Ksp4)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081105 Shredder/3.0b1pre] (nightly) (W2Ksp4)

I can't reproduce, from zip file, with either current or new profile.

MacOSX only ?
Version: unspecified → Trunk
Should be Mac and Tb/Linux, the three places there's no packages file to control what gets shipped.

The NS_NOINTERFACE is something else, it's been around for a while now, Fx and Tb, the useGlobalHistory is bug 463176, and this is just because gloda landed with all its extension skeleton still intact.
Assignee: nobody → philringnalda
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: Warning: Duplicate resource declaration for 'gloda' ignored (and two errors) → De-extensionify gloda
Gloda, I served with extensions, I knew extensions, extensions were friends of mine. Gloda, you're no extension (anymore).
Attachment #346621 - Flags: superreview?(bienvenu)
Attachment #346621 - Flags: review?(bienvenu)
Attachment #346621 - Flags: superreview?(bienvenu)
Attachment #346621 - Flags: superreview+
Attachment #346621 - Flags: review?(bienvenu)
Attachment #346621 - Flags: review+
Comment on attachment 346621 [details] [diff] [review]
A whack at it
[Checkin: Comment 5]

thx, Phil - this seems to build and work fine on the Mac, though I didn't do an "official" build.
http://hg.mozilla.org/comm-central/rev/d5be46adae02
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
I don't wanna be a grinch, but after checkin of this patch I still get the exactly same warning and errors.
I get it in the tinderbox build
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081107 Shredder/3.0b1pre
and in my own (fresh) build
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081107 Thunderbird/3.0b1pre
Screenshot from the error console: Tinderbox build - Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081107 Shredder/3.0b1pre - 1226066261
(I don't know where this third error cames from, never seen this before)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached patch Whack more moles (obsolete) — Splinter Review
I'd sort of vaguely like to know why that single declaration is a duplicate declaration, but not badly enough to spend any more time on this, particularly when using resource://gre/modules/ is The Right Thing, as demonstrated by every other Cu.import use in the tree (except the one freaky resource:///modules/ in browser/).
Attachment #347038 - Flags: superreview?(bienvenu)
Attachment #347038 - Flags: review?(bugmail)
(In reply to comment #8)
> when using resource://gre/modules/ is The Right Thing

Actually, I believe that resource://app/modules/ is The Right Thing if it is an app-specific module and not a platform-wide module.
Once we're running on XULRunner, resource://gre/ points inside the XULRunner directory while resource://app/ points into our app's directory.

What I don't understand though is why gloda is in its own .jar and doesn't just share messenger.jar.
(In reply to comment #8)
> Created an attachment (id=347038) [details]
> Whack more moles

Yes, this seems to work much butter. :)
I applied this patch on my own build and now I doesn't get this warning anymore. If I than force another warning in the error console (opening the addressbook) and click on that link, than I only get one of the mentioned errors now.

 Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]
Comment on attachment 347038 [details] [diff] [review]
Whack more moles

thx, Phil.
Attachment #347038 - Flags: superreview?(bienvenu) → superreview+
Attached patch Whack, throw corpses in /app/ (obsolete) — Splinter Review
Indeed, app.
Attachment #347038 - Attachment is obsolete: true
Attachment #347067 - Flags: superreview?(bienvenu)
Attachment #347067 - Flags: review?(bugmail)
Attachment #347038 - Flags: review?(bugmail)
Comment on attachment 347067 [details] [diff] [review]
Whack, throw corpses in /app/

Wups, didn't notice I was midairing my sr, I'll just carry that along with me :)
Attachment #347067 - Flags: superreview?(bienvenu)
Status: REOPENED → ASSIGNED
Duplicate of this bug: 463953
Comment on attachment 347067 [details] [diff] [review]
Whack, throw corpses in /app/

Per bug 463775, it's okay for us to add our own make rule to install stuff under modules.

As such, let's make gloda install its stuff to dist/bin/modules/gloda, and the namespace be app/modules/gloda/BLAH.

With that change made, we will be able to lose the code in the unit test that creates the "gloda" resource alias programatically.  r-'ing just because there's some non-trivial changes to be made here.
Attachment #347067 - Flags: review?(bugmail) → review-
Only fully-tested clear through to removed-files.in removing in the Tb/Win installer, but I'm reasonably sure (as sure as I can be without running my own update server) that it'll work right elsewhere too.

Don't suppose we could just leave those removed-files in for a few weeks, and then decide that anyone who hasn't updated their nightly yet deserves pain and confusion? I'd really rather not carry that albatross around our neck for all time, just to clear out a few nightlies.
Attachment #347067 - Attachment is obsolete: true
Attachment #347728 - Flags: superreview?(bugzilla)
Attachment #347728 - Flags: review?(bugmail)
As KaiRo points out, we really need to get done with removing those files pretty quickly, since SeaMonkey wants to ship places, which also ships a modules/utils.js, so it would be a nice thing if we didn't ship a beta including them in modules and clutter up the whole removed-files situation.
Flags: blocking-thunderbird3?
yes, I think we should do this before b1, if possible.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
(In reply to comment #1)
> I can't reproduce, from zip file, with either current or new profile.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081113 SeaMonkey/2.0a2pre] (home, optim default) (W2Ksp4)

I can reproduce, presumably since some other packaging bug was fixed:
{
Warning: Warning: Duplicate resource declaration for 'gloda' ignored.
Source File: file:///.../objdir/mozilla/dist/bin/chrome/gloda.manifest
Line: 1
}
(In reply to comment #19)
> I can reproduce, presumably since some other packaging bug was fixed:
Ah, this would explane why I get the warning notwithstanding I applied this patch. And the patch worked fine 6 days ago.
Comment on attachment 347728 [details] [diff] [review]
Whack, corpses and blood everywhere, v.4

hooray for philor!  There was some minor rotting in the context, so I'm going to attach the de-rotted version of the patch.
Attachment #347728 - Flags: review?(bugmail) → review+
This is just philor's v4 patch but applies cleanly to the recent trunk.
Attachment #347728 - Flags: superreview?(bugzilla) → superreview+
Comment on attachment 348533 [details] [diff] [review]
philor's v4 with context failures de-rotted
[Checkin: Comment 25]

carrying forward reviews, adding checkin-needed keyword. I'll mark the bit-rotted patch obsolete, if it's not already
Attachment #348533 - Flags: superreview+
Attachment #348533 - Flags: review+
Attachment #347728 - Attachment is obsolete: true
(In reply to comment #23)
> (From update of attachment 348533 [details] [diff] [review])
> carrying forward reviews, adding checkin-needed keyword. I'll mark the
> bit-rotted patch obsolete, if it's not already

I forgot to say, Phil, can you co-ordinate landing of this with Andrew please? I think he wants to update extensions at the same time.
Done, and with any luck, done.

http://hg.mozilla.org/comm-central/rev/641c14ca5210
Status: ASSIGNED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b2pre) Gecko/20081118 SeaMonkey/2.0a2pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/4b5e00c182be
+http://hg.mozilla.org/comm-central/rev/641c14ca5210)

V.Fixed
Status: RESOLVED → VERIFIED
Attachment #346621 - Attachment description: A whack at it → A whack at it [Checkin: Comment 5]
Attachment #348533 - Attachment description: philor's v4 with context failures de-rotted → philor's v4 with context failures de-rotted [Checkin: Comment 25]
Blocks: 468344
You need to log in before you can comment on or make changes to this bug.