Closed Bug 463292 Opened 11 years ago Closed 11 years ago

overflowing text-shadow in XUL labels not fully repainted

Categories

(Toolkit :: XUL Widgets, defect, P3)

1.9.1 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla1.9.1b3

People

(Reporter: whimboo, Assigned: roc)

References

(Depends on 1 open bug)

Details

(Keywords: testcase, verified1.9.1)

Attachments

(3 files)

Attached image Overlapped blur effect
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081105 Minefield/3.1b2pre

Having multiple lines inside the all tabs or ctrl-tab panel the blurring effect of the preview text is overlapped by the beneath preview box. See the attachment.

Steps:
1. Open at least 4 tabs
2. Click all tabs or ctrl+tab (hold down ctrl key here)
3. Use the mouse to focus a preview in the first row and afterwards the one beneath

You will notice that the bottom area of the preview text is overlapped by the beneath preview.
Flags: in-litmus?
roc, is Gecko behaving correctly here?
I'm confused. I don't see anything wrong in the testcase. By "preview text" do you mean "Minefield Start Page"? What do you think is overlapping it?
The text-shadow of "Minefield Start Page" is cut off.
Oh that.

That looks like a problem in the overflow area calculation for the XUL text box with shadow, leading to it not being repainted when we repaint the bottom tab preview.
Assignee: nobody → jag
Component: Tabbed Browser → XUL
Product: Firefox → Core
QA Contact: tabbed.browser → xptoolkit.widgets
Flags: wanted1.9.1? → blocking1.9.1+
Priority: -- → P3
Assignee: jag → nobody
Assignee: nobody → roc
Attached file Testcase
Click to see the bug.
Attached patch fixSplinter Review
-- Override ComputesOwnOverflowArea to return true so that nsBox::SyncLayout doesn't ignore what we set
-- Make nsDisplayXULTextBox return the overflow area as its bounds
Attachment #349332 - Flags: superreview?(dbaron)
Attachment #349332 - Flags: review?(dbaron)
Whiteboard: [needs review]
Roc, can we get a better summary for this bug?
Summary: Blur effect of preview title is overlapped by beneath preview → overflowing text-shadow in XUL labels not fully repainted
Comment on attachment 349332 [details] [diff] [review]
fix

r+sr=dbaron
Attachment #349332 - Flags: superreview?(dbaron)
Attachment #349332 - Flags: superreview+
Attachment #349332 - Flags: review?(dbaron)
Attachment #349332 - Flags: review+
Whiteboard: [needs review] → [needs landing]
Initially landed on mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/fb2326fcfc36
http://hg.mozilla.org/mozilla-central/rev/026147c91538
and then backed out due to crashes caused by bug 430332:
http://hg.mozilla.org/mozilla-central/rev/9eaf91dad68c
and then relanded on mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/607791c2f989
and thus fixed on both mozilla-central and releases/mozilla-1.9.1.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → mozilla1.9.1b3
Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081206 Shiretoko/3.1b3pre.

Roc, is it something we can cover in the test-suite?
Severity: minor → normal
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
OS: Windows Vista → All
Hardware: PC → All
Right now it's quite difficult to test. But later we'll have the ability to test invalidation properly.
Added as Litmus test meanwhile:
https://litmus.mozilla.org/show_test.cgi?id=7439
Component: XUL → XUL Widgets
Flags: in-litmus? → in-litmus+
Product: Core → Toolkit
QA Contact: xptoolkit.widgets → xul.widgets
Version: Trunk → 1.9.1 Branch
This bug is NOT FIXED on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20081127 Minefield/3.1b3pre ID:20081127040457 and every build after that (verified using testcase #2).

I'd like some discussion on this before its re-opened as the blur is being cut off by the box in that test case.
Do you have a screenshot? It looks fine to me with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090617 Shiretoko/3.5pre ID:20090617031317
You need to log in before you can comment on or make changes to this bug.