Inbox fragmentation and size issue cause thunderbird to be scary for regular users

RESOLVED DUPLICATE of bug 286888

Status

RESOLVED DUPLICATE of bug 286888
10 years ago
10 years ago

People

(Reporter: taltamirh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/525.19 (KHTML, like Gecko) Chrome/0.3.154.9 Safari/525.19
Build Identifier: 

I originally encountered the problem when my mother (whom I convinced to switch to mozilla) said thunderbird was refusing to download new emails. It was giving her an "inbox full" error. She tried deleting all her mail to no avail.

Some reading helped me find out that the problem is that it fragmented and the solution is to "compact folder" on inbox. This is all nice and dandy but how to I prevent it from crippling the usage of non tech savvy people whom I help switch to thunderbird?

well there is an option, that is NOT on by default, do automatically compact a folder when it will save X space. Wonderful feature.
Except it automatically engages almost every time (especially with default setting of 50KB savings) and when it does you can NOT delete files from the inbox. (for example, you are getting some messages. It starts compacting, you now cannot delete files, getting a pop up error instead, until it finishes). This is again very bothersome and SCARY for an average user.

This bug report is actually a compound issue, I think several things need to change to make thunderbird less scary and smoother to use.

1. Automatic folder compacting should be on by default for everyone.
2. If the inbox goes above 4GB (which was the case with my mother), rather then telling the user that the folder is full (prompting them to incorrectly and useless delete messages), it should display a notice that it must compact it, and display a progress bar. Not an error message.
3. If even after compacting size exceeds 4GB, some sort of file splitting must occur, rather then forcing the deletion of messages to fit in new ones.
4. Some sort of log based operation must be created to allow normal operation during a folder compression (as it is can take a while, making thunderbird seem, crippled).

Reproducible: Always

Steps to Reproduce:
see details
Actual Results:  
see details

Expected Results:  
see details
This is a bug database you can only have one issue (you listed 4) in one bug. More than one issues in one bug report makes the bug usually invalid.

1) is already reported
2) not needed with 1) and it can be just a full folder with 4gb without having deleted messages in the folder-file.
3) not easy to solve because one file = one folder it
4) a compact folder operation means that you have to rewrite the whole folder file and that also means that you can not access this file during the operation.

marking as dupe of bug 286888
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286888
(Reporter)

Comment 2

10 years ago
2. Should still be an issue because it can be disabled by a user. On by default does not solve it, just diminishes it.
3. Yes, but it makes no sense for it to refuse to download more email when there is still free HDD space.
4. Hence I suggested a log based operation. That way you can make changes that go into a log / new file.
Step 1: start creating a new inbox file
step 2: user makes a change, commit change to a temp file
Step 3: new inbox file finished, replacing old with new one.
Step 4: modify new inbox with data from temp file.
(Reporter)

Comment 3

10 years ago
the reason i put them together is that solving ANY of of the four should help a lot.
(Reporter)

Comment 4

10 years ago
sorry for posting again, by help alot i meant solve the issue, the issue is not that there is compacting or whatever, the issue is that it scares "average joe" users.
There is also a bug for activating auto compacting by default but that will not happen unless the "Get new messages" while autocompacting issue would be solved.
As I said you posted like 4 different bugs, some are already in bugzilla (search for it) and some will never implemented in a way you suggest.
You need to log in before you can comment on or make changes to this bug.