Closed Bug 463361 Opened 13 years ago Closed 13 years ago

Firefox infinitely loops opening new tab

Categories

(Firefox :: File Handling, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 167320

People

(Reporter: majuki, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

When opening http://www.rememberthemilk.com/services/modules/googlecalendar/ics.rtm I chose to open with Firefox and chose the 'do every time' option.  This resulted in Firefox infinitely opening tabs.  I was able to close Firefox so it's not a huge issue - it also wouldn't have occurred without the Redirect Remover extension though the potential is there for problems.  Note that while this is unusual behaviour to select such options, I have had to do that exact behaviour for some image types to force Firefox to be the viewer.

Reproducible: Always

Steps to Reproduce:
1. Go to a url with a file extension Firefox doesn't recognize (rtm by example)
2. Select 'Open File' and set to Firefox
3. Check the 'do this every time' option
Actual Results:  
Firefox opened blank tabs infinitely

Expected Results:  
Error: unable to open filetype .rtm (as it had already prompted with the download dialog, it shouldn't keep trying to download over and over)
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167320
You need to log in before you can comment on or make changes to this bug.