"Automatically add outgoing e-mail address" should include OSX System Address Book

RESOLVED DUPLICATE of bug 391057

Status

Thunderbird
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 391057
9 years ago
9 years ago

People

(Reporter: Niels Van Hoef, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20081006 Shredder/3.0a3

Automatically add outgoing e-mail address should include OSX System Address Book as a possible address book to choose from.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
This option will be available when we enable writing to the Mac OS X address book, which is bug 391057. There won't be any changes required specific to enabling this option when bug 391057 happens, so I'm marking it as a duplicate of that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391057

Comment 2

9 years ago
Hi Mark

I think this is actually an easier challenge than bug 391057, that bug requires translation between TB address fields and OSX , which according to bug 391057 is hard. 

Fixing this problem with vcard just requires passing the attachment to Address Book, which already knows how to handle vcards. 

I think translating twice (vcard -> TB -> Address Book) would likely be less effective, as such double translations usually are. 

- Mitra
Mitra, sorry I have to disagree. Our vcard support is incomplete, for one thing we don't support home addresses properly, and we're not even at version 2.1. So we'd be very limited, plus we'd have to find a way to poke the vcards at the OS X address book even if it liked them.

Comment 4

9 years ago
I think that's what I mean, I wouldn't have thought TB had to support Vcards in order to open an attached file (which happens to be a Vcard) in the user's Address Book.

Comment 5

9 years ago
Ok - sorry about this ignore me, I'm getting my bugs confused and my comments on vcards relate to the similar butdifferent bug 480676
You need to log in before you can comment on or make changes to this bug.