Tabs not restored after shutdown (application-quit notification missing?)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: steve, Unassigned)

Tracking

1.9.1 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081106 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081106 Minefield/3.1b2pre

With the 'show my windows and tabs form last time' option enabled tabs are NOT rester if you shout down the computer.

Sorry if this is a dupe but I's not quite the same as the other bugs I could find.

Addons: Chatzilla, nightly tester tools, read it later.

Reproducible: Always

Steps to Reproduce:
1.open some tabs or change open URIs
2. shutdown linux (I'm using new gnome fast switch applet)
3. restart and run FFx
Actual Results:  
tabs are not remebered, reverts to older state

Expected Results:  
tabs all restored
(Reporter)

Comment 1

10 years ago
I guess Firefox is not seeing the shut down event and doing its stuff?

Comment 2

10 years ago
WORKSFORME. Are you by any chance clearing your History data at shutdown? If so, this would be a DUPE of bug 398817.
Whiteboard: [worksforme?]
(Reporter)

Comment 3

10 years ago
Simon, thanks, in what way do you mean? If I exit Firefox before shut down all is well.  It should be the same behaviour either way.

Updated

10 years ago
Keywords: qawanted
Whiteboard: [worksforme?]

Comment 4

10 years ago
Right, we don't seem to be informed about the impending shutdown.
Component: Session Restore → Startup and Profile System
Product: Firefox → Toolkit
QA Contact: session.restore → startup
Summary: Tabs not restored after shutdown → Tabs not restored after shutdown (application-quit notification missing?)
Version: unspecified → 1.9.1 Branch

Comment 5

5 years ago
Is this still an issue? Removing the "qawanted" keyword; If the help of QA is needed, please add back the keyword.
Keywords: qawanted

Comment 6

5 years ago
Alexandra, the qawanted keyword seems to be pretty clear here: this is an UNCONFIRMED bug that needs QA to try and reproduce the steps listed in comment 0 and either confirm the bug or mark it as WORKSFORME/INCOMPLETE.
Flags: needinfo?(alexandra.lucinet)
Keywords: qawanted

Comment 7

5 years ago
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20130722 Firefox/25.0

It WFM with FF 23 beta 8 (Build ID: 20130722172257) and Nightly 25.0a1 (Build ID: 20130722172607) with a clean profile and, also, a dirty one with the following addons installed: yahoo toolbar; amazon toolbar; ebay toolbar; Download Helper; Adblock Plus; Greasemonkey; Crash me Now!; Personas Plus; all my tabs are restored after Ubuntu shutdown (with Firefox running); including pinned tabs and logins are saved.

Based on the testing results, marking as Resolved WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(alexandra.lucinet)
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.