Allow extensions to be crosslisted as themes

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Policy
--
enhancement
RESOLVED WONTFIX
9 years ago
2 years ago

People

(Reporter: mkaply, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
We have a unique situation in that we're creating extension/theme combos. Unfortunately because they are an XPI, there is no way to have them listed as themes in amo.

There should be a way with amo to designate that something should be crosslisted in themes if it is both a theme and an extension.
Hm, I am not sure about that. IIRC, currently a theme is considered to be only a "skin" for Firefox. The instant it adds functionality, it's an extension. Of course, it's a fuzzy line (are fancy UI effects "functionality" yet?), but I am unsure if it would help the user to expect installing a theme (only) and realizing they changed not only the look of their browser but also added extension functionality.

In other words: What's so bad about having your extension marked as such?
Component: API → Public Pages
OS: Mac OS X → All
QA Contact: api → web-ui
Hardware: PC → All
(sorry for the component confusion, I think this is a policy discussion first, and if approved would turn into an implementation thing)
Component: Public Pages → Policy
QA Contact: web-ui → policy
I think is WONTFIX as well. Something is either a theme or extension. Sure, there are extensions that can skin parts of the browser. But unless something is listed as a theme in the add-ons manager, it's not a theme. For example, Personas is definitely an extension, even though it lets you quickly theme your browser.
(Reporter)

Comment 4

9 years ago
The problem is that it is a theme and an extension. So if people are looking for themes, they don't find them.

What we'd like is for our themes to be discoverable when people are searching for themes.

The problem is the search is based on things in the theme category not things that include the word "theme"

And disagree with the assertion that things are extensions or themes. We have built a scenario where a theme and an extension are bundled together, so it offers both.

I consider it a theme that comes with an extension, not an extension that comes with a theme.
There's an Appearance category for extensions.

People that are looking in the themes section have certain expectations, one of which is that themes don't have JavaScript or any other code and won't do anything but modify the CSS and images of their browser.

Marking WONTFIX. I don't think we're interested in creating this confusion of well-defined add-on types that have been around for a long time.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.