Changing radio button for "Place a copy in" doesn't work (sent mail folder)

RESOLVED FIXED in Thunderbird 3.0b1

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: standard8, Assigned: Bienvenu)

Tracking

({regression})

Trunk
Thunderbird 3.0b1
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fix baking on the trunk])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Go into account manager, select Copies & Folders, under "Place a copy in" select a different option (either other or sent folder on). Select OK, and then go back into account settings.

Result: the radio button is back in its original setting.
Flags: blocking-thunderbird3?
... though if you really select a folder on another server it does work.

I think there's another bug also about restoring it to "<folder> on <server>" like it used to be.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
OS: Mac OS X → All
Hardware: PC → All
(Assignee)

Comment 2

10 years ago
this is pretty bad...I'll double check that it still happens, and see if there's anything on the error console.
(Assignee)

Comment 3

10 years ago
the problem appears to be in setPickersState, we don't know what the currentAccount is - it's undefined, so we bail out early. But we seem to be setting it in other places...perhaps we're clearing it, or somehow don't have access to it.
(Assignee)

Comment 4

10 years ago
Created attachment 351068 [details] [diff] [review]
proposed fix

this fixes it for me, but I'll do some more testing.
Assignee: nobody → bienvenu
Attachment #351068 - Flags: superreview?(bugzilla)
Attachment #351068 - Flags: review?(bugzilla)
(Assignee)

Comment 5

10 years ago
I believe this was a regression from getting rid of rdf in the account setting dialog but I don't know that for sure.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

10 years ago
I'm going to put this in the b1 bucket, because if we do a respin, I'd like to take this fix.
Target Milestone: --- → Thunderbird 3.0b1
(Assignee)

Comment 7

10 years ago
I'd be surprised if SM didn't have the same problem
(Assignee)

Comment 8

10 years ago
jminta might have some thoughts on this.
Whiteboard: [has patch for review]
(Reporter)

Comment 9

10 years ago
Comment on attachment 351068 [details] [diff] [review]
proposed fix

This looks good to me.
Attachment #351068 - Flags: superreview?(bugzilla)
Attachment #351068 - Flags: superreview+
Attachment #351068 - Flags: review?(bugzilla)
Attachment #351068 - Flags: review+
(Assignee)

Comment 10

10 years ago
I've landed this on the trunk. I would want this for a respin, so I'm going to leave this open for now.
Whiteboard: [has patch for review] → [fix baking on the trunk]
(Assignee)

Updated

10 years ago
Blocks: 467813
(Assignee)

Comment 11

10 years ago
marking fixed - we're tracking changes for the respin with a tracking bug.
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.