Javascript: error log can allocate idefinite amount of memory

VERIFIED FIXED

Status

SeaMonkey
General
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Devoti Paolo, Assigned: John Taylor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m17) Gecko/20000724
BuildID:    2000072408

There is no limit to the amount of memory allocated by the javascript: error
log. It can allocate so much memory that the pc becomes almost dead because of
swapping.

Reproducible: Always
Steps to Reproduce:
1.open mozilla
2.url to javascript: to open the error log
3.open system monitor with cpu load and allocated memory
4.url to http://www.dynamicdrive.com/dynamicindex13/trailer3.htm
5.get in view the system monitor

Actual Results:  because of the partly incompatible script in the page there is
an uninterrupted flood of errors making the the allocated memory to grow
indefinitely

Expected Results:  number of errors growing to a maximum given(configurable?) number
Perhaps I simply did not saw it, is nice to have the opportunity to clear the
log (without closing everything)

Comment 1

18 years ago
I think the error service has a finite length wrapparound buffer. But the window 
will just keep showing errors. Also, what is with this script that the errors 
don't stop?
Assignee: jband → mccabe
Status: UNCONFIRMED → NEW
Component: JavaScript Debugger → Browser-General
Ever confirmed: true

Comment 2

18 years ago
CCing ben.  There's a bug for a 'clear' button at 43427; comments on that
requested.
(Reporter)

Comment 3

18 years ago
The applet is one of those animated mous trail. It is handling mouse movement 
and time to manage the trail location and fading. In short it is calling 
continuously a function that uses something incompatible.
the error is
document.trailspriteX has no properties
line 78 column 0

Comment 4

18 years ago
Reassiging to jtaylor, who might be able to fix it as part of the 'clear' button
fix.
Assignee: mccabe → jtaylor

Comment 5

18 years ago
Nominating for beta3.
Keywords: nsbeta3
(Assignee)

Comment 6

18 years ago
Created attachment 12536 [details] [diff] [review]
Patch, also fixes bug#43427. Any comments?
(Assignee)

Comment 7

18 years ago
Created attachment 12537 [details] [diff] [review]
Patch, also fixes bug#43427. Any comments? Are we still able to change console.dtd?
(Assignee)

Comment 8

17 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
Works for Me
Platform: PC
OS: Windows 98
Mozilla Version: 2000100508

Marking as Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.