When configuring mozilla with a relative path, make check fails in js/src

RESOLVED FIXED in mozilla1.9.2a1

Status

defect
P2
normal
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: benjamin, Assigned: jimb)

Tracking

({fixed1.9.1, regression})

Trunk
mozilla1.9.2a1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I don't usually use client.mk to build, but rather run ../src/configure directly.

This causes `make check` to fail in js/src:

/usr/bin/python ../../../src/js/src/config/check-sync-dirs.py ../../../src/js/src/config ../src/config
TEST-FAIL | build file copies are not in sync
file(s) found in: /builds/mddepend-removal/src/js/src/config
differ from their originals in: /builds/mddepend-removal/ff-release-m32/js/src/config

This is caused by the toplevel configure passing --with-sync-build-files=../src

It should use an absolute path instead of a relative path.
Assignee: nobody → jim
Status: NEW → ASSIGNED
Attachment #348302 - Flags: review?(benjamin) → review+
Whiteboard: checkin-needed
This was pushed to tracemonkey and will come back to mozilla-central at the next merge.
Whiteboard: checkin-needed
Merged to mozilla-central without apparent incident.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Not sure how tracemonkey patches are getting to 1.9.1, but this needs to land in 1.9.1.
Flags: blocking1.9.1+
Whiteboard: [needs 1.9.1 landing]
jim, can you push this to 1.9.1?
Priority: -- → P2
Landed in 1.9.1: http://hg.mozilla.org/releases/mozilla-1.9.1/rev/7cad83a4f30a
Whiteboard: [needs 1.9.1 landing]
Keywords: fixed1.9.1
(In reply to comment #3)
> Merged to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/6c75d8666e90
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.2a1
Version: unspecified → Trunk
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.