If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Ctrl+Tab panel leaves focus in content area

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Tabbed Browser
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

({access})

Trunk
Firefox 3.6a1
access
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
STR:

1. open 5 tabs
2. open http://google.com
3. hit Ctrl+Tab (release Tab but keep Ctrl pressed)
4. hit the down arrow

Expected:
Focus moves to the 5th preview.

Actual:
Autocomplete popup for google's search field opens.
(Assignee)

Comment 1

9 years ago
Created attachment 347058 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Flags: blocking-firefox3.1?
(Assignee)

Comment 2

9 years ago
Created attachment 347059 [details] [diff] [review]
more
Attachment #347058 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Depends on: 463802
(Assignee)

Comment 3

9 years ago
Created attachment 347060 [details] [diff] [review]
more
Attachment #347059 - Attachment is obsolete: true
I can't reproduce this using today's Minefield nightly (testing on OS X 10.5.5).

Can you?
(Assignee)

Updated

9 years ago
Depends on: 465076
(Assignee)

Updated

9 years ago
Flags: blocking-firefox3.1?
(Assignee)

Updated

9 years ago
No longer depends on: 463802
Depends on: 463802
(Assignee)

Updated

9 years ago
No longer blocks: 447580
(Assignee)

Comment 5

8 years ago
Fixed by bug 465076.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.6a1
Verified fixed on trunk with builds on Windows and OS X like Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090722 Minefield/3.6a1pre ID:20090722034040

Is there already an automated test for the focus part?
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
(Assignee)

Comment 7

8 years ago
No, there's currently no test for this.
You need to log in before you can comment on or make changes to this bug.